Community Forum

Peacock Premium's "Channels' interface not working for days

Highlighted
Regular Visitor

Peacock Premium's "Channels' interface not working for days

If we try to use that, there's an endless rolling spiral/ball, and it never connects to the channels guide/interfac. though the rest of Peacock is working. .  Had worked before this week. What's with that?

Highlighted
Official Employee

Re: Peacock Premium's "Channels' interface not working for days

Hi @bmazor26

Thanks for using the Xfinity Forum to report this. I'm not sure what caused it to stop working but would be happy to help troubleshoot and/or add the channels for you if you're unable to do it on your end. By chance, have you tried to perform a system refresh? 

  1. Press the A button on your remote control, or visit the Help section in Settings. (Saying “System Refresh” into your Voice Remote will take you to step three.)
  2. Highlight the System Refresh tile, and press OK.
    The Troubleshoot screen with the System Refresh option selected.
  3. Please remember that performing a System Refresh will interrupt all X1 TVs and recordings in your home for up to 10 minutes. If you would like to proceed, highlight Refresh Now, and press OK.

  4. Once the System Refresh is in progress, don't unplug or turn off any of your TV Boxes, which will automatically restart during this process.

  5. The X1 Welcome screen will appear after the TV Box restarts.

  6. Once the System Refresh has been completed, your TV Box will return to live TV.

  7. The System Refresh feature can only be used once within a 24-hour period, so if you continue to experience issues, you can Schedule a Call to have a specialist troubleshoot your issues.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!