Community Forum

New Box not connecting to X1

New Poster

New Box not connecting to X1

Hello. The cable box in my bedroom recently threw up an error about the memory card not working and I couldn’t rewind or pause live tv so I ordered a replacement.

Today, the new box came (RNG 150N) and it fired up ok, but it will not connect to X1. I can watch TV with the new box, but I can’t access anything my DVR or anything because that’s all X1 related. All the connections are tight, rebooted the main box and the new box several times, still nothing. I just swapped back to the old box for the time being because at least I can still access my DVR on it, because the X1 still connects fine. Any clue what might be the problem? Defective box, perhaps?
Diamond Problem Solver

Re: New Box not connecting to X1

The RNG150 is a bad substitute for the XiD(has way less features). Take it to your local service center for a swap

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
New Poster

Re: New Box not connecting to X1

Thank you for the info! I just took the box they sent me. I am able to request a certain kind of box? Do you happen to know what a better replacement would be? Just curious.
Diamond Problem Solver

Re: New Box not connecting to X1

The XG2 is a solid replacement or another XiD, just not a RNG150

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
New Poster

Re: New Box not connecting to X1

Thank you sir!