Community Forum

Lightning hit in area. Lost power. X1 Box no longer sending signal to tv

Highlighted
New Poster

Lightning hit in area. Lost power. X1 Box no longer sending signal to tv

My x1 Box was knocked off due to lightning. Everything came back on. But the box is no longer sending a signal to the tv. Even changed tvs to see if it was the tv. No luck. This is the 2nd time this particular type of box (xg2) has done this. The previous boxes didn't do this. I have it plug into a surge protector already. But it seems particularly sensitive and unfixable. I get tired of taking  it back to Comcast. is there anything I can do to fix and keep from happening in future?

Highlighted
Diamond Problem Solver

Re: Lightning hit in area. Lost power. X1 Box no longer sending signal to tv

Not really, it’s electronic and you can’t control lightning. Have you tried using the rca or coax connections on the box to get service or does it not have power?

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
Highlighted
New Poster

Re: Lightning hit in area. Lost power. X1 Box no longer sending signal to tv

It gives me the welcome screen for a few minutes and then goes to no signal.

Highlighted
New Poster

Re: Lightning hit in area. Lost power. X1 Box no longer sending signal to tv

@CCAndrew update: it actually started working with coax cable. Is there a way to get it to work with hdmi again?

Highlighted
Diamond Problem Solver

Re: Lightning hit in area. Lost power. X1 Box no longer sending signal to tv

The port probably fried after the lightning strike. Did you try a different HDMI cord?

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
Highlighted
New Poster

Re: Lightning hit in area. Lost power. X1 Box no longer sending signal to tv

Yeah. Tried different hdmi cord. Didn't work.