Community Forum

DVR box sound disappears for hours or days and then returns for hours or days

latichever
Contributor

DVR box sound disappears for hours or days and then returns for hours or days

For the past few months, I've had sound on all channels disappear for hours or days and then mysteriously reappear for hours, days, or weeks.

 

The audio problem is only on the input for the DVR box, not on the input from my Roku. So, it's not a problem with the TV

 

I've done all the standard troubleshooting and a comcast phone agent did a "health status check" and said everything's fine coming into my house.

 

I have another TV on a non-dvr cable box and this one never has the audio issue.

 

I've swithed the hdmi cable to a different input on my TV and is not a fix. I will swap in a new cable but I don't see how it could be the  hdmi cable. If that doesn't work they'll send me a new DVR box.

 

Should that fix the problem. Or is there anything else I can try?

 

Thanks.

 

Update: okay, this is weird, the sound was working, put it on mute and left for a while, came back, and no sound. But still sound on the roku input, which I can mute/unmute with the xfinity remote.

Rustyben
Expert

Re: DVR box sound disappears for hours or days and then returns for hours or days


@latichever wrote:

For the past few months, I've had sound on all channels disappear for hours or days and then mysteriously reappear for hours, days, or weeks.

 

The audio problem is only on the input for the DVR box, not on the input from my Roku. So, it's not a problem with the TV

 

I've done all the standard troubleshooting and a comcast phone agent did a "health status check" and said everything's fine coming into my house.

 

I have another TV on a non-dvr cable box and this one never has the audio issue.

 

I've swithed the hdmi cable to a different input on my TV and is not a fix. I will swap in a new cable but I don't see how it could be the  hdmi cable. If that doesn't work they'll send me a new DVR box.

 

Should that fix the problem. Or is there anything else I can try?

 

Thanks.

 

Update: okay, this is weird, the sound was working, put it on mute and left for a while, came back, and no sound. But still sound on the roku input, which I can mute/unmute with the xfinity remote.


pick one end of the HDMI cable and pull it out then re-insert listening and feeling for the lock-in "click". then do the remaining end. Is the set top box connected directly to the TV?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
latichever
Contributor

Re: DVR box sound disappears for hours or days and then returns for hours or days

Thanks for your reply.

 

The solution was within your ballpark. 

 

I swapped in a brand new HDMI cable, problem solved.