Community Forum

Control4 Xfinity IP Driver

Highlighted
Regular Visitor

Control4 Xfinity IP Driver

I have an XG1v4-A box with new FW Version:  AX014AN_4.0p4s1_PROD_sey

This FW has broken the ability for the IP Control to work and not able to get an IP address anymore.

All its says under Remote Control>Ip Control is Enabled = True.  No Mac or IP is listed below that which normally there is.  Ive swapped the box already and its not a router issue.  This wasn't an issue with the 3.2 ish firmware, but seems IP Control isn't working with this new 4.0 firmware.  Thanks for any help.

Highlighted
Frequent Visitor

Re: Control4 Xfinity IP Driver

Still having the same issue on a recently acquired XG1v4... 

 

 

Highlighted
Regular Visitor

Re: Control4 Xfinity IP Driver

Just tried again today and was able to get this working. Cable box FW still on 4.0.

Use Composer Pro on laptop and not Composer Express.

My issue before was the cable box wasn’t getting an IP address. Randomly I noticed an Arris device connected to router so figured that must be cbl box and it was.

I also found on Comp Express app I wasn’t able to change the IP in advanced settings on the Xfinity IP driver. Instead went into PC version of Composer Pro and the Connection > Network tab and changed the IP there.

Then the thing that made it work was hitting the “Pair to Xfinity” button under Sys Design>Xinfity Driver >Actions tab.

Also noticed when I goto cbl box secret menu (Hold Xfinity 3 secs, down, down, 3) and goto Remote Controls, I do see IP Control enabled True, but still dont see any IP or Mac listed. But IP control does work.