Community Forum

Xfinity Stream TV: createDrmSession. TVAPP-00101

Highlighted
Regular Visitor

Xfinity Stream TV: createDrmSession. TVAPP-00101

Hi, 

 

I'm experiencing issues accessing the Xfinity Stream app on my Roku devices. I get prompted with error: createDrmSession. TVAPP-00101. My device is already connected to my home wifi, so I tried re-installing the app, and re-starting my router and modem - no luck.  I did upgrade my modem recently, which is compatible with my internet speed and recommended by Xfinity. Not sure if this has anything to do with the issue? I reached out to customer service, but no reply. Help please. Thanks in advance!

Highlighted
Expert

Re: Xfinity Stream TV: createDrmSession. TVAPP-00101


@francescaE wrote:

Hi, 

 

I'm experiencing issues accessing the Xfinity Stream app on my Roku devices. I get prompted with error: createDrmSession. TVAPP-00101. My device is already connected to my home wifi, so I tried re-installing the app, and re-starting my router and modem - no luck.  I did upgrade my modem recently, which is compatible with my internet speed and recommended by Xfinity. Not sure if this has anything to do with the issue? I reached out to customer service, but no reply. Help please. Thanks in advance!


on a smart phone/tablet run the xfinity my account app, go to internet tab and touch the modem (only one there?). compare the shown serial number to your modem/gateway that you are currently using HFC MAC address. is it identical character by character?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Regular Visitor

Re: Xfinity Stream TV: createDrmSession. TVAPP-00101

Hey @Rustyben! Thanks for the help.

 

When I access the internet tab on the Xfinity My Account app, it reads "There aren't any devices set up yet." Do you have recommendations on how to proceed?

Highlighted
Expert

Re: Xfinity Stream TV: createDrmSession. TVAPP-00101


@francescaE wrote:

Hey @Rustyben! Thanks for the help.

 

When I access the internet tab on the Xfinity My Account app, it reads "There aren't any devices set up yet." Do you have recommendations on how to proceed?


recently moved? kept old email for new account?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
New Poster

Re: Xfinity Stream TV: createDrmSession. TVAPP-00101

@Rustyben what do you do if it isn't identical or even close for that matter?

Highlighted
Expert

Re: Xfinity Stream TV: createDrmSession. TVAPP-00101


@confused123456 wrote:

@Rustyben what do you do if it isn't identical or even close for that matter?


I do not understand the question, sorry. try calling 800-Comcast and select billing. the agent can review your account details and fix the ability to sign in to the app.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
New Poster

Re: Xfinity Stream TV: createDrmSession. TVAPP-00101

I have had the exact same issue and now the problem is solved. I downloaded the Xfinity My Account app and noticed the modem / router stated was the one that I had returned. Whenever I would try to change the credentials myself, I would get a response that it couldn't be done at this time. I did notice that the return was pending for the router / modem that I had sent back. With much persistence I was finally able to talk to a support rep. I explained that the new modem / router was not registered and with that they were able to fix the issue. I had to read them the MAC address from the new unit.