Community Forum

RAI and MediaSet don't work on Roku TV Xfinity Stream

Highlighted
New Poster

RAI and MediaSet don't work on Roku TV Xfinity Stream

I added RAI and MediaSet Italia to my TV package.  I am able to stream the channels from the app on my phone but not on a Roku TV or a Roku box.  When I search for the channels on Roku TV they come up but when you try to watch them the app closes and takes you back to the home screen.

 

I scrolled thru all of the channels and neither one shows up in the list.  Any ideas?

Highlighted
Expert

Re: RAI and MediaSet don't work on Roku TV Xfinity Stream


@chemtev wrote:

I added RAI and MediaSet Italia to my TV package.  I am able to stream the channels from the app on my phone but not on a Roku TV or a Roku box.  When I search for the channels on Roku TV they come up but when you try to watch them the app closes and takes you back to the home screen.

 

I scrolled thru all of the channels and neither one shows up in the list.  Any ideas?


I have escalated your issue to the Comcast Team available to these forums. Check back often for a reply in this thread from a Comcast Official Employee.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Frequent Visitor

Re: RAI and MediaSet don't work on Roku TV Xfinity Stream

I used to have a Roku, but it may have changed since then. Worth a try. 

Just by chance, did you authenticate the added channels with the Roku. It's kindof a pairing between Comast and the Roku where it will give you a link code. 

Also, you have to be signed in to your Comcast account first.

If Comcast already responded to your issue, please let us know what they did!

Highlighted
Official Employee

Re: RAI and MediaSet don't work on Roku TV Xfinity Stream

Hi @chemtev

 

We appreciate you for sharing your experience while trying to enjoy RAI and MediaSet from your Roku TV. Sorry for the issues you're running into. I can help troubleshoot to help ger this fixed. By chance, have you tried the steps suggested by @jhqbraille, authenticate the added channels with the Roku, signed in to your Comcast account first? 

 

If so, I'd love to chat with you in a private message and complete some troubleshooting. To send a private message, click on my name, "ComcastChe," and then click send a message. Please include your first and last name and account number, and we can proceed from there. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!