Community Forum

No Primary user on account, only Manager

Highlighted
Regular Visitor

No Primary user on account, only Manager

I am having a similar issue to so many here in that have no Primary User on my account. I have tried all of the tobleshooting suggestions and nothing works.

 

I am the only user on my account but listed as just a 'Manager' with no ability to create new users. From looking at others issues here, I think it must have happened 7 or 8 years ago when I moved but am just now noticing it because I can't sign in on some 3rd party TV streaming apps.

 

When the account was originally opend I had a different email address that was the Primary.  Soon after, I created a secondary user and began to use that more and I eventually deleted the original user that must have been the Primary user. I just assumed that the system would make the only user left the Primary User since that is logical!!!  Around the same time I also moved from a house to a condominium that has special deal with Comcast where the entire building and all of the units in it use Comcast and most of the  cost of service is included in our HOA fees. With that transfer, my account number remained the same however.

 

I have tried using the old, original email to login (with all variations of my password over the years) to no avail.

 

@ComcastJonathan

 

 

Highlighted
Gold Problem Solver

Re: No Primary user on account, only Manager

Double check your UserIDs on your home system with the Lookup tool at https://www.xfinity.com/id. After you enter the requested information you'll see a list of the UserIDs on your account and an indication of which one is Primary. Be aware that the Primary UserID online doesn't always correspond with a name on your billing statement.

Highlighted
Regular Visitor

Re: No Primary user on account, only Manager

Been there, done that.

 

This is a flaw and bug with Comcast's back-end database and how their system manages user IDs.  It seems to happen to account holders who change addresses and/or change primary user IDs. Don't know how to fix it but it involves customer service intervention unfortunatly.

 

Waiting on a response from @ComcastJonathan who seems to be one that is working on these types of issues.