Community Forum

links in email not working

Highlighted
Contributor

links in email not working

links in email not working for a few days.

WHY?

New Poster

Re: links in email not working

I am having the same issue.  

Expert

Re: links in email not working


@HDRock wrote:

links in email not working for a few days.

WHY?


Did you try right-clicking on them to see if you can open them that way?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: links in email not working

Thank you very much!  That works!

 

New Poster

Re: links in email not working

Thank you, that worked for me, too, but it is there a reason why we have to open links that way now?  

Expert

Re: links in email not working


@jamp725 wrote:

Thank you, that worked for me, too, but it is there a reason why we have to open links that way now?  


I'm not really sure.  I suspect it may be your browser settings, especially the pop-up blocker.  If you disable it, can you then single or double-click on a link to open it?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Contributor

Re: links in email not working

Thanks for the reply

The way I was able to open them Before was to right click then click open In new tab,  The problem is fixed the pop up blocker  Deal that was the problem I don't know why it Started acting up but it's fixed ,Just a single left click and they work now 

New Poster

Re: links in email not working

To the best of my knowledge, which is admittedly limited (I'm 69!), I'm not using a pop-up blocker.  My browser is Chrome.  I've searched the settings and extensions and cannot find a pop-up blocker.  I don't mind doing the right-click/open in new tab route.  It's just another little annoyance. Thanks for your help!

Expert

Re: links in email not working


@jamp725 wrote:

To the best of my knowledge, which is admittedly limited (I'm 69!), I'm not using a pop-up blocker.  My browser is Chrome.  I've searched the settings and extensions and cannot find a pop-up blocker.  I don't mind doing the right-click/open in new tab route.  It's just another little annoyance. Thanks for your help!


I use Chrome too.   When in the settings, scroll down to "Advanced".  In the section "Privacy and security" scroll down to "Content settings".  Scroll down to "Popups and redirects".  Click on that and you will see your pop-up blocker settings.  If you haven't changed it, the default is that it should be enabled.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: links in email not working

Thank you!!!  That was the problem.  Strange how it's never been a problem before and then all of a sudden it is.  I just hope that I'm not overwhelmed by unwanted pop-ups now!  Thanks again.

Frequent Visitor

Re: links in email not working

That worked!!!!   THANK YOU

Frequent Visitor

Email Links not working

Yes the right click and open in a new tab works,

 

But why won't the left clickd work like it did a week ago?

 

Is this the new normal or will it be fixed?????

Frequent Visitor

Re: Email Links not working

I use Chrome and did the following:  Settings / Advanced / Privacy & Security / content settings / Pop-up & Redirects and make sure allowed is on...

Frequent Visitor

Re: Email Links not working

Thank you very much. That worked.  I know that I did not dive that deep into Chrome and change it, so some other factor must of changes.

New Poster

Re: links in email not working

I use Chrome also but in Advanced settings I only see three options: Email Safe list, POP Settings for Other Apps, and Spam Filtering. How do I go further in your instructions.  And do you enable Spam filtering?  A Comcast rep told me to uncheck that when I was having trouble receiving some emails a month ago.

Frequent Visitor

Re: links in email not working

under advanced, go to privacy and security and go to content settings, then to pop ups and redirects, and make sure ALLOWED is turned on.

   Hope this helps

      John

New Poster

Re: links in email not working

Under Advanced, I don't have Privacy and Security as and option, just the three options I mentioned.  I am getting to Settings from the Gear icon, is this correct?

Frequent Visitor

Re: links in email not working

This used for a laptop, I get to settings using the three dots on the top right corner of the Chrome browser, next to where you type the URL in.

New Poster

Re: links in email not working

Now I got to it using those three dots.  thanks.  One more question: will I start getting all kinds of pop ups?

New Poster

Re: links in email not working

I have not noticed any increase in the pop-ups since I disabled mine.  

New Poster

Re: links in email not working

Thank you!  I posted the same question and tried right clicking and that works.  However, I don't know why this is happening now.  I have not had a problem linking anything in the past.  

Frequent Visitor

Re: Email Links not working

Thanks,

 

This worked for me.

Frequent Visitor

Re: Email Links not working

You're welcome, glad it worked ..

New Poster

Re: links in email not working

Thank you! By going through the internet settings- Advanced... worked beautifully! Thank you!!!

Frequent Visitor

Re: links in email not working

You're welcome, glad it worked

Not applicable

Re: Email Links not working

Which settings do you refer to, Chrome or xfinity email?  My links aren't working.

 

Not applicable

Re: links in email not working

This worked!!  Thanks very much!!

Frequent Visitor

Re: Email Links not working

Chrome settings

New Poster

Re: Email Links not working

Thanks, that works!

New Poster

Re: Email Links not working

Setting for comcast email - I checked settings and did not see option there.

Chrome? I could not figure out were the settings are located. 

Same problem they popped up something on a single email I got about links and it seems to have made links in all emails not work. Useless if they have done this..

Frequent Visitor

Re: Email Links not working

You access the Chrome settings using the 3 dots in the upper right corner of screen.

I use Chrome and did the following:  Settings / Advanced / Privacy & Security / content settings / Pop-up & Redirects and make sure allowed is on...

New Poster

Re: Email Links not working

Yes, I looked further through the comments and saw a "three dots" in the bar far right, went in and allowed...I will check now, that its solved. Geez...

New Poster

Re: links in email not working

I found a successful fix for Google Chrome. My wife's computer has been doing this and now mine. 

1-Go to "Help" under the menu of three dots in the upper right corner and do an updatefor Google Chrome by selecting "About Google Chrome".

2-Go into an Xfinity email and allow pop-ups. That is done with a "pop-ups" icon to the left of the three dots in the upper right corner.

 

Hope this works for you as it did for me. 

New Poster

Re: links in email not working

Try this  if you are using Chrome

  1. Go to Google Chrome Settings. ...
  2. You can open the Settingspage by clicking on the icon with three dots in the right side of the address bar; this will open up a dropdown menu called Customize and control Google Chrome, select Settings in the menu
  3. Scroll down to Advanced, select
  4. In the Privacy and security section scroll down to Content Settings
  5. Scroll to Pop-ups and redirects
  6. Move the selector to Allowed
Contributor

Re: Email Links not working

It worked. Went to content settings, advanced , pop up & re directs and added connectxfinity.com to allow and now I can open links in email. Thank yuou. Never had to do that before but it works.

Frequent Visitor

Re: links in email not working

Yes, left clicking and opening in a new tab DID work.  It's not as convenient as direct open but it'sd a work around. Thank you.

Contributor

Re: Email Links not working

That worked, but none of us can understand why, all of a sudden, clicking on a link doesn't take you to your destination.  It would be nice if we were advised about changes being made!

New Poster

Re: links in email not working

This totally worked for me. Thank you.

Contributor

Re: links in email not working

He's referring to "settings" for CHROME, not settings for Comcast e-mail.

Expert

Re: Email Links not working


@Five4Fighting wrote:

That worked, but none of us can understand why, all of a sudden, clicking on a link doesn't take you to your destination.  It would be nice if we were advised about changes being made!


This isn't something Comcast did; it's a result of an update in Chrome from Google that affected how links are treated in Xfinity Connect.  Hopefully it will be taken care of soon.


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: links in email not working

that doesn't work either.

New Poster

Re: links in email not working


@HDRock wrote:

links in email not working for a few days.

WHY?



@HDRock wrote:

links in email not working for a few days.

WHY?


 

New Poster

Re: links in email not working

I had the same problem and discovered the solution by mistake. When I clicked on one of the links in the email, I noticed something in the upper right hand corner of the screen. I clicked the link again and in the upper rigt hand corner said it was blocked and I click on it and was able to unblock it. Hope this helps. I have had no more issue since

 

New Poster

Re: links in email not working

This was a great help.  Worked great.  Thanks.

New Poster

Re: links in email not working

I am having the same problem. Started in the past couple of weeks.

Contributor

Re: links in email not working

If youo have chrome try this. Up top ata the dots go to settings and scroll down to advanced and click. Find content settings thn pop-up & redirects hit arrow and go to allow & add https://connect.xfinity.com. then you just open as you always did 

New Poster

Re: links in email not working

Finally something that actually worked!!

Many thanks