Community Forum

it is a year later and you still havent fixed NFL games in Spanish?

Highlighted
New Poster

it is a year later and you still havent fixed NFL games in Spanish?

I was looking for some answers and didnt really find any. My 88 year old mother is trying to figure out why she has to watch the Bears game inj Spanish. You people are less than compentent!

Highlighted
New Poster

Re: it is a year later and you still havent fixed NFL games in Spanish?

I came here to post a similar question.  For me, only NFL games on Fox broadcast in Spanish even though much like you, I verified that SAP feature is off and I have reset my cable box.  No other channels come in Spanish, and "regular" non-sports shows on Fox come in English...just when NFL is on.  Seems like a common problem they aren't addressing or trying to fix based on seeing other posts on this forum.  Sorry don't have an answer for you, but just letting you know you're not alone.

Highlighted
New Poster

Re: it is a year later and you still havent fixed NFL games in Spanish?

Okay after digging through the forums for like 30 minutes, I think I found the fix. I did it and haven't had any Spanish broadcast for the NFL game for like 10 mins after I did the switch.  You have to turn off "video description" in your settings.  If you have an X1 remote, hit the "B" button (above the number pad) and that should bring up your settings screen.  Scroll down to "video description" and make sure it's turned to "off".  That seemed to help me at least.  Good luck!

Highlighted
New Poster

Re: it is a year later and you still havent fixed NFL games in Spanish?

Hi there.  I lookes at other forum answers, and this helped me.  My daughter's boyfriend just joined the Bears and I was dying for ENglish commentary.

 

While checking your SAP setting is a first good step, it may not be the fix.  It wasn't for me either...and only NFL games were coming in for Spanish for me as well (even though SAP was turned to "off").  After digging through the forums for like 30 minutes, I think I found the fix. I did it and haven't had any Spanish broadcast for the NFL game for like 10 mins after I did the switch.  You have to turn off "video description" in your settings.  If you have an X1 remote, hit the "B" button (above the number pad) and that should bring up your settings screen.  Scroll down to "video description" and make sure it's turned to "off".  That seemed to help me at least.  Good luck!