Community Forum

Re: Bad signal to MSNBC

Highlighted
New Poster

Re: Bad signal to MSNBC

2020 in two days problems with MSNBC for 2 years. Are all teck people incompetent. Who is to blame Comcast or MSNBC. Is it time to switch ips. My average Xfinity bill is 400 bucks. What's the reason.
Highlighted
Diamond Problem Solver

Re: Bad signal to MSNBC

Channels come in on different frequencies, something is impeding the frequency MSNBC is coming in on. Maybe others that you don’t watch or get. Check to make sure your cables are tight and in good repair, remove any extra splitters and possibly have a tech out to troubleshoot further. The size of your bill doesn’t affect whether channels come in or not.

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
Highlighted
New Poster

Re: Bad signal to MSNBC

Twice in the last month MSNBC hasn't come on even tho all the other cable channels are available. This only happens on our 2 large box receivers and NOT the little box for bedroom. And in the evening when Rachel Maddow show comes on. Seems fishy to me. 

Highlighted
Diamond Problem Solver

Re: Bad signal to MSNBC

Channels come in on different frequencies, something is impeding the frequency MSNBC is coming in on. Maybe others that you don’t watch or get. Check to make sure your cables are tight and in good repair, remove any extra splitters and possibly have a tech out to troubleshoot further. The programs on MSNBC coming in. Why would it be fishy if Comcast owns MSNBC?

The smaller box (DTA) doesn’t need as good/clean signal for channels to come in, like the other boxes do

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
New Poster

Re: Bad signal to MSNBC

My MSNBC is suddenly not coming in. And I have tried both restarting and system refresh and nothing. And my cables are fine. Help!