Community Forum

Premium HD Channels are in Spanish, even though my Basic Language is set for English

Highlighted
New Poster

Premium HD Channels are in Spanish, even though my Basic Language is set for English

In our Master Bedroom, all of the Premium HD Channels are in spanish now and we aren't sure why.  Setting indicates that our Audio is English and the lower HD channels are still in English.  Where do I switch the Premium Channels Audio to English again??  Just for the cable box in the Master Bedroom, not the Living Room cable box.

Highlighted
New Poster

Re: Premium HD Channels are in Spanish, even though my Basic Language is set for English

I came here to post a similar question.  For me, only NFL games broadcast in Spanish even though much like you, I verified that SAP feature is off and I have reset my cable box.  No other channels come in Spanish, and "regular" non-sports shows on Fox come in English...just when NFL is on.  Seems like a common problem they aren't addressing or trying to fix based on seeing other posts on this forum.  Sorry don't have an answer for you, but just letting you know you're not alone.

Highlighted
New Poster

Re: Premium HD Channels are in Spanish, even though my Basic Language is set for English

Okay after digging through the forums for like 30 minutes, I think I found the fix. I did it and haven't had any Spanish broadcast for the NFL game for like 10 mins after I did the switch.  You have to turn off "video description" in your settings.  If you have an X1 remote, hit the "B" button (above the number pad) and that should bring up your settings screen.  Scroll down to "video description" and make sure it's turned to "off".  That seemed to help me at least.  Good luck!