U

Wednesday, August 9th, 2023 3:26 PM

Closed

XB8 not working with ethernet switch

I have an issue where signal is not getting passed from our Xfinity router (XB7 or XB8) to the switch which connects to other devices. We were using the Xb7 router with a D-Link 1000Mbs 24 port switch. Been using the switch for 5 years. Seems like every few years something on the Xfinity router changes and causes us to lose internet connections across the switch. We upgraded to the XB8 and same issue - no internet through the switch. 

We have cycled the switch - multiple times.

Checked that all ports work correctly on switch.

Ran cable continuity checks between router and switch and switch to all downstream devices. All good.

XB8 is NOT in Bridge mode.

All four ports on the XB8 work

What could be causing this problem?

 

Official Employee

 • 

1K Messages

11 months ago

@user_c49896 Good morning, and Happy Friday! Thank you for reaching out to our Community Forums Team for assistance with your internet connection. We truly appreciate the level of detail that was included in your post, that helps tremendously if we know what you have already tried. Do you still have your XB7 to reconnect and try that one to see if it works? 

2 Messages

@XfinityKassie​ We exchanged the XB7 for the XB8 at a local Xfinity store. 

The problem mysteriously resolved itself. 

Official Employee

 • 

734 Messages

@user_c49896, That is wonderful to hear that issue has been resolved with the swapping of the modem. I did find some forums posts that may have some more insight for troubleshooting steps others have used for switch and connection issues: https://forums.xfinity.com/conversations/your-home-network/ethernet-switch-unable-to-identify-more-than-one-computer/602dadcfc5375f08cdd40de3, https://forums.xfinity.com/conversations/your-home-network/no-connection-with-xfinity-gateway-and-unmanaged-switch/602db12fc5375f08cd481028. 

 

Working from home myself, I definitely know how important it is to have your internet connection up and running. I would be happy to check back in with next week after you have time to test, to ensure everything is still working well. Does that work for you?

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

1 Message

Hi, I recently tried to connect my netgear switch and have been unsuccessful. From the admin page, my ports say up but they are continuing to receive 0 bytes transferred.. yet, another one of the connections direct to the gateway works just fine as well as wifi. Why doesn't it transmit to the Switch. (netgear gs308ep)

Official Employee

 • 

1.9K Messages

Hey @user_38f280, thanks for reaching out through Xfinity Forums regarding your Netgear switch. We would be happy to help you with troubleshooting. 

Please send us a direct message with your name and service address, so we can assist you further. To send us a Direct Message, you will need to sign in to the Forums if you are not. Then you will need to locate and click on the "Direct Message" icon located in the upper right corner of this page. Next, click the "New Message" (paper & pencil) icon and type "Xfinity Support" in the to line, and select "Xfinity Support" from the drop-down list. You can proceed to type your message in the text area near the bottom, and press enter to send the message. Please let me know if you have any questions.

 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick
forum icon

New to the Community?

Start Here