E

Visitor

 • 

3 Messages

Tue, Nov 30, 2021 5:42 PM

Wifi Speed

I recently upgraded from the 600Mbps internet plan to the 900Mbps one.  The Xfinity app reports that the speeds to the gateway are within the contracted speed, but when I test it out on my iPhone using a internet speed app I continue to get about 500-600Mbps.  Now I know that there are several factors influencing speed to a wireless device, but given the fact that I was getting 500-600Mbps with the 600Mbps plan, but see no increase now I'm on the 900Mbps plan makes me think somethings wrong.  I called Xfinity and all they were able to do was confirm I'm getting the correct speed to the Gateway.  Any thoughts?

Thanks!!

Accepted Solution

XfinityTony

Official Employee

 • 

361 Messages

2 m ago

Hello, @EtheP! What is the maximum speed your iPhone is rated for over WiFi? Smaller devices, like phones, often do not have enough WiFi antennas to get the highest speeds we offer. I would also look at things like distance and interference. Here is a great article to help you get the most out of your WiFi: https://www.xfinity.com/support/articles/improve-your-wireless-home-network

(Edited: Grammar)

(edited)

Visitor

 • 

3 Messages

@XfinityTony

That's a good suggestion.  I'll have to check into it.  Thanks!!! 

Visitor

 • 

3 Messages

@NoNoBadPuppy 

Thanks I'll look into it.  Most of the advise is about a router which doesn't work, mine works just fine, I'm just not getting the 900Mbps speed  with my iPhone.  More like the 600Mbps that I had prior to the upgrade.

New to the Community?

Start Here