rraman's profile
rraman
Much Appreciation
Stamp of Approval
Conversation Starter

Frequent Visitor

 • 

6 Messages

Wed, Apr 29, 2020 1:00 PM

Your ISP's DHCP is not functioning properly - ASUS router

Hi,  I am having the exact same issue as this thread https://forums.xfinity.com/t5/Your-Home-Network/Your-ISP-DHCP-not-working/td-p/3239115  after a comcast outage in my area.  I have followed the xfinity troubleshooter and done multiple cycles of both soft and hard reboots of my cable modem (netgear CM500) but continue to see this message in my router.   The Xfinity troubleshooter eventually recommends i schedule an appointment, but before i take that step in these COVID-19 times, I was wondering if anyone on this forum can help.  

 

In the thread above, @ComcastChe  was able to solve it by sending a provisioning signal to the modem. 

Responses

Accepted Solution

ComcastChe

Official Employee

 • 

6.1K Messages

1 y ago

@EG, Yep! In both cases, after provisioning the modem, the issue was resolved. I'm going to follow up with @rraman in a couple of days just to make sure everything is good. 

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Solution.tick
ComcastChe

Official Employee

 • 

6.1K Messages

1 y ago


@rraman wrote:

Hi,  I am having the exact same issue as this thread https://forums.xfinity.com/t5/Your-Home-Network/Your-ISP-DHCP-not-working/td-p/3239115  after a comcast outage in my area.  I have followed the xfinity troubleshooter and done multiple cycles of both soft and hard reboots of my cable modem (netgear CM500) but continue to see this message in my router.   The Xfinity troubleshooter eventually recommends i schedule an appointment, but before i take that step in these COVID-19 times, I was wondering if anyone on this forum can help.  

 

In the thread above, @ComcastChe  was able to solve it by sending a provisioning signal to the modem. 


Hi @rraman, Thank you for reaching out. I can assist you as well. Just send a private message and we can go from there.  Chat with you soon!

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Solution.tick
rraman

Frequent Visitor

 • 

6 Messages

1 y ago

@ComcastChe, thanks for the speedy help resolving it. Things are looking good now.
ComcastChe

Official Employee

 • 

6.1K Messages

1 y ago

You're welcome! It was great chatting with you. I'll be here if you need anything. 

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Solution.tick
EG

Expert

 • 

87K Messages

1 y ago

Was the solution the same as in the linked thread in the OP ? 

 

.@rraman  .@ComcastChe  

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

Frequent Visitor

 • 

19 Messages

1 y ago

Can you share the solution with the rest of us?

 

My router hasn't worked since Comcast's two day outage on 4/28 and 4/29.  I can connect through my modem, but not if my router is connected.

EG

Expert

 • 

87K Messages

1 y ago


@RegularGuy99 wrote:

Comcast claimed they could not provision my Cisco DPC 3008 for 'bridging' to let it work with a router.  


FWIW, the 3008 is already a layer 2 bridge / straight cable modem. There is nothing to "bridge".

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

Frequent Visitor

 • 

19 Messages

1 y ago

Comcast claimed they could not provision my Cisco DPC 3008 for 'bridging' to let it work with a router.  They directed me to Cisco who pointed out that they have no access to Comcast's DHCP server where the modem provisioning comes from.

I can't seem to get past the Comcast techs who make me power cycle equipment and check cables over and over again.

 

I neglected to mention that my modem/router configuration was working for almost a year - up until Monday evening.  Any change that occurred had to be outside of my home.  Somewhere in Comcast's outside plant.

rraman

Frequent Visitor

 • 

6 Messages

1 y ago

@RegularGuy99  Comcast sent a provisioning signal to my cable modem.  I assume that resets the DHCP lease/dynamic IP address.  It could be that during your system maintenance you got a short term DHCP lease that isn't renewing or working correctly - but this is just me speculating. 

EG

Expert

 • 

87K Messages

1 y ago


@ComcastChe wrote:

@EG, Yep! In both cases, after provisioning the modem, the issue was resolved. I'm going to follow up with @rraman in a couple of days just to make sure everything is good. 


Thank you for replying .@ComcastChe ! 😊

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick
rraman

Frequent Visitor

 • 

6 Messages

1 y ago


@RegularGuy99 wrote:

Comcast claimed they could not provision my Cisco DPC 3008 for 'bridging' to let it work with a router.  They directed me to Cisco who pointed out that they have no access to Comcast's DHCP server where the modem provisioning comes from.

I can't seem to get past the Comcast techs who make me power cycle equipment and check cables over and over again.


I don't know how to get past those techs who stick to the basic playbook of troubleshooting. I got lucky on this forum with a quick no-nonsense solution from @ComcastChe  (who won't be back for another 2-3 days) so hopefully someone else sees this and can help you out.  Try asking support to reprov your modem. 

darkangelic

Expert

 • 

2K Messages

1 y ago


@rraman wrote:

@RegularGuy99 wrote:

Comcast claimed they could not provision my Cisco DPC 3008 for 'bridging' to let it work with a router.  They directed me to Cisco who pointed out that they have no access to Comcast's DHCP server where the modem provisioning comes from.

I can't seem to get past the Comcast techs who make me power cycle equipment and check cables over and over again.


I don't know how to get past those techs who stick to the basic playbook of troubleshooting. I got lucky on this forum with a quick no-nonsense solution from @ComcastChe  (who won't be back for another 2-3 days) so hopefully someone else sees this and can help you out.  Try asking support to reprov your modem. 


Except that @RegularGuy99  specifically wrote that they can connect when directly connected through the modem, but not when the router is involved. This obviously points to the router as the culprit,  and there's nothing wrong with the  modem.

Personally, I would reset both the modem and the router to factory defaults and try setup again.

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick
rraman

Frequent Visitor

 • 

6 Messages

1 y ago

I don't know what to say bud.  It's possible you are correct, but without actually getting hands on, on his network i don't know.  All i can tell you is what i know from my scenario:

1. i had the exact same scenario, as well as others including the thread i referenced in my initial post.  If i connect my laptop directly to the cable modem i had connectivity, but when my router made a dhcp client request to the cable modem it didn't work.

2. the router settings were unchanged for nearly 2 years. And remains unchanged even now.  And no bridging or any of that.  so nothing "changed" in the router settings.

3. the only change event that occured was a comcast service outage, resolved by comcast, after which our routers were no longer getting DHCP requests serviced correctly.  (speculation, not fact. often during service maintenance, a temporary DHCP lease is provided. i don't know if that has any bearing here)

4.  multiple power cycles and soft resets had no effect

5. after the cable modem was reprovisioned (which reset the dhcp lease and gave my cable modem a new IP), everything is fine. 

 

not trying to debate correctness here. all i'm sharing is what worked for me, and why.  if it helps @RegularGuy99   then great.   Thanks for pitching in to help as well. 🙂 

andyross

Silver Problem Solver

 • 

6.9K Messages

1 y ago

DHCP is based on the MAC address of the device connected to the modem. It's possible the MAC address for the router was messed up somewhere in Comcast's provisioning. You can often alter the MAC in the router. You can then reboot the modem and see if it now properly gets an address. I have had to do this a few times, several years ago.

ComcastChe

Official Employee

 • 

6.1K Messages

1 y ago

Hi @RegularGuy99

We appreciate you for using the Forums to share your experience. I can understand why this would be frustrating. I'd like to investigate and help get this resolved. Honestly, it could be an issue on our end or an issue with your router. 

After a factory reset is completed on the modem and router, and the issue is still present, the first thing I check for on my end is provisioning because DHCP may not have been renewed (I can normally tell when looking at the IP Address using the tools we use). From there, I would be able to determine if the cause is your router. I'm not saying a provisioning signal resolves the issue every time, but for the most part, when situations like this occur, it is the most common fix. 

@RegularGuy99 , if you're still in need of assistance, please send me a private message with your first and last name (and the name of the account holder) and the house number associated with your service address. To send a private message, click on "ComcastChe" and then click send a message. 

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Solution.tick

New to the Community?

Start Here