jpsmcool's profile

New Poster

 • 

1 Message

Thu, Mar 11, 2021 7:00 PM

Port Forwarding stopped working seemingly out of nowhere

Hi, today the ports I had forwarded for months just stopped working out of nowhere randomly, and no new ports will work even if I try to do it on another computer.

The ports I had open were:

-8123

-25565

-65342

-65343

I can still connect to those ports on the local network using the device IP, but I can't use the public IP.  I have an Xfinity XFI gateway, model number TG3482G.

Does anyone know how to fix this?

Responses

flatlander3

Regular Contributor

 • 

176 Messages

2 m ago

Just a few posts down there are two threads on it.

 

@johnnydrama23found a fix.  You might have run into a firmware update that changed how reserved dhcp address and the firewall works.  https://forums.xfinity.com/t5/Your-Home-Network/Port-Fowarding-with-xFi/td-p/3416100

 

Most implementations of dhcp are based on opensource isc-dhcp.  I know in the BSD/Linux version, it doesn't specify if a reserved IP address has to be inside or outside the dhcp address pool.  It just pings an address to see if it's in use before passing out an address.  Port forwards are usually done on IP's that are not in the pool with firewall rules, static assigned or reserved, which makes sense because the pool is supposed to change all the time.  Xfinity may have changed the firewall behavior to only allow the port forward to addresses that are WITHIN your dhcp pool.

 

If you set a client up with a static IP address and it's outside of the dhcp pool, your port forward may no longer work.  You may have to set the client up to use dhcp, and reserve an address for it inside the dhcp pool for the port forwards to work.  Don't use static IP's inside the dhcp pool.  Reserve the address instead.  A static address may work for a while, but if your client is down, the server may pass out the address to something else, and you'll have a conflict and network chaos when your client comes back up.

 

Release notes if they are going to do a firmware push, or if this is just an app/cloud configuration deployment issue would be helpful, but I don't see them anywhere.  *If this is a bug Xfinity knows about, they may change the function of this at any time.

 

 

Visitor

 • 

1 Message

i have the exact same problem.  About 20 ports opened and on April 13, 2021 it all stopped working and hasn't worked since.

I just spent an hour with Tech Support and although they did what they could, still not working.  The "server" is working fine, no changes or updates.  I verified LAN connection to the Ports in question and it responds fine.  I verified that the IP is Reserved and it IS within the DHCP range, and always has been.

I also turned OFF Advanced Security, but no change.

Comcast even forced a resync on the modem with same results.

This seems like an easy function to implement, why doesn't it just work they way it's supposed to?

New to the Community?

Start Here