U

Visitor

 • 

4 Messages

Sat, May 28, 2022 5:51 PM

Closed

DMZ - Stopped working.

I have an Xfinity supplied ARRIS Group, Inc. TG1682G modem/router.

Around the second week of May 2022, my DMZ stopped working and it had been working since 2018.  And up until May 2022, I was able to set everything up via the 10.0.0.1 address after logging in. 

But now everything is required to configure via the website: https://internet.xfinity.com/network/advanced-settings/dmz

And like the OP, I turned off Advanced Security (as others have noted to do) and it still does not work even though the DMZ shows as enabled and set to my LAN side router's WAN IP address (10.0.0.2).

Also odd, is the very next day when I log back into the website and check the DMZ, I see it is back to disable.

And even stranger, when I call Xfinity tech support (and got pushed back to the more experienced tech person) she said she can no longer access my modem from her end and it tells her to go to myxfi???!!!!  So, tech support can't log into my modem anymore.

I have a feeling the website is not passing the settings to the modem/router.

Yes, I can probably go to bridge mode but was avoiding that because of various reasons that don't need to be discussed here and I like the double NAT with both modems and the DMZ set for my modem.

Anyone figure this out yet?

This post was created from this reply on different post

Accepted Solution

Visitor

 • 

4 Messages

5 months ago

Hey all,

In case anyone is following this or maybe someone looking up my exact problem finds this thread, well, I have good news for you all.  I solved the issue.

In most cases, one sets a device needing a static IP to have that static IP outside the DHCP range of the router, ie, the Xfinity router is set for DHCP  10.0.0.100 - 10.0.0.254 then you set the static IP to anything under .100 so that the router doesn't give out that static IP inadvertently on a reboot.

So if my router behind the Xfinity router was set to 10.0.0.100 and my router behind the Xfinity router were to reboot at the same time the Xfinity router rebooted (maybe I just rebooted them both on a schedule), and just maybe someone's cell phone reconnects to the Xfinity router before my router reboots fully and the Xfinity router gives the cell phone .100 and then my router finishes booting with a static IP of .100 so there would be conflict, one would assume.

Well for some odd reason that is not how the Xfinity router behaves.  If you want to set up your backend router to be on the DMZ on the Xfinity router you MUST set your router's WAN IP to be the first IP in the DHCP.  Very strange.  Once you do that you can then set up the DMZ under the Xfinity router and it will note that even though its DHCP range starts at .100, it will table your router as "fixed IP" at .100 and will give the next DHCP request .101.   I've tested variations and found this to be fact.

So now your router will be .100 and it will appear as a fixed IP of .100 on the Xfinity router and the DMZ will now route correctly.  And the next device requesting an IP will get .101 and so on.

The logic evades me but I've been in this business long enough to find the workaround and not worry too much as to why it works, as long as it does.

Visitor

 • 

4 Messages

7 months ago

One more strange thing.

My LAN side router has a fixed WAN port of 10.0.0.2 and when I view the device via the Xfinity portal on the "device details" it shows it as 10.0.0.2.

But when I add a port forward and pick my router from the list of devices and set the port it shows the IP as 10.0.0.100 and NOT the 10.0.0.2.

So for the heck of it, I changed the DMZ to .100, and still no go.

I'd guess this is related to the DMZ not forwarding to my router.

XfinityDevin

Official Employee

 • 

731 Messages

@user_d7b022
Good afternoon! That is strange, and we would love to help you with this. Since you have worked with our technical team already, I would like to take a look at the notes to see what has already been tried. Can you send us a direct message to get started, please? 

Here's the detailed steps to Direct Message us:

• Click "Sign In" if necessary
• Click the "Direct Message" icon (upper right corner of this page)
• Click the "New message" (pencil and paper) icon
• Type "Xfinity Support" in the to line and select "Xfinity Support" from the drop-down list
• Type your message in the text area near the bottom of the window
• Press Enter to send your message

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

4 Messages

OK, I did the direct message.

Here are a bit more details.  I "think" the Arris assumes my Tenda Router is 10.0.0.100 when in fact it is set to with a static IP of 10.0.0.2.

I have guests in my rental home so I don't want to mess with it now.

But I'll be there in July and at that time I can mess with this at that time.

In a normal world, one usually sets a static IP outside of the DHCP range as I had done.  Others with this similar issue noted you should set the static IP at the first of the Arris DHCP range and when the Arris sees that as being used by my Tenda router it will hand out the next DHCP request at 10.0.0.101.  And if that is the trick to fix this, then when I'm down there I can try that.

The next thing I can do is disconnect the Tenda first and wipe out the Arris DMZ settings, restart the Arris and then play with connecting the Tenda with a static IP of  .2  and try setting it up all over again.

Here are the screenshots:

(edited)

forum icon

New to the Community?

Start Here