M

Thursday, May 16th, 2024 1:35 AM

Xfinity Streaming on computer Chrome just 3 dots

My streaming through chrome on my computer was working a few nights ago.  Last night when I clicked on link from google to go to xfinity stream, the normal 3 dots show up on middle of screen as usual.  But instead of loading it just stays on the three dots.  I have tried clearing cache.  Doesnt work.  Is there something that happened 2 days ago?  Any idea how I can get it back to working?

Problem Solver

 • 

537 Messages

1 month ago

Try a different browser - see if the same results.

Official Employee

 • 

1.3K Messages

29 days ago

Hello there moonman68 thank you so much for using our Forums to contact our team. Please let us know if you are still having issues. We are here to help! 

 

1 Message

29 days ago

Same here.  Worked fine for well over a year, now getting:

Something went wrong.

Your guide isn't loading right now. Please wait a few moments, then try again.

(Error TVAPP-00502)

Official Employee

 • 

988 Messages

Hello @user_plqaa8, Thanks for leaving a comment on our community forum. Are you having the same issue on all browsers or just Chrome? Have you cleared your cache and cookies, along with browsing data?

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick
forum icon

New to the Community?

Start Here