abchezold's profile

Regular Visitor

 • 

2 Messages

Fri, May 10, 2019 4:00 PM

App on ROKU stops working about every 3 days, need to reinstall to get it working again

After 3 or so days, the Xfinity app on our Roku stops working. The app opens for a second or so, shows what appears to be the "Getting Started" page as if we had just installed it, then closes (or crashes). Each time this happens we have to reinstall the app and re-authorize, and go over the whole setup steps again. Is there any way someone at Comcast can diagnose this problem? It's extremelly annoying having to reinstall the app this often to get around this horrible bug.

 

Please help! Thanks.

This conversation is no longer open for comments or replies and is no longer visible to community members.

Responses

Rustyben

Expert

 • 

24K Messages

2 y ago


@abchezold wrote:

After 3 or so days, the Xfinity app on our Roku stops working. The app opens for a second or so, shows what appears to be the "Getting Started" page as if we had just installed it, then closes (or crashes). Each time this happens we have to reinstall the app and re-authorize, and go over the whole setup steps again. Is there any way someone at Comcast can diagnose this problem? It's extremelly annoying having to reinstall the app this often to get around this horrible bug.

 

Please help! Thanks.


after you uninstall the xfinity beta channel and are back in the roku menu, unplug the roku device for 2-3 minutes from all cables. then plug back in and reinstall, and accept the terms and conditions.

ComcastKenF

Official Employee

 • 

8K Messages

2 y ago

abchezold, to chime in, what roku are you using? 

 

Ken

Regular Visitor

 • 

2 Messages

2 y ago

Following up, as it is still happening regularly and still very much a pain. Reinstalling the app/turning off for 2 minutes, or even completely RESETTING the Roku and setting it up again does nothing to fix this issue. Also the latest app update doesn't address this. I have the latest version of ROKU ULTRA that is compatible with the Xfinity app. Now we have noticed that sometimes we are using the app, then hit the home button, and then try to launch it again a few seconds or minutes later, and the app gets into this state.

 

Is there ANYWAY to troubleshoot this? I can try to collect logs/etc, but there doesn't appear to be any way of doing that from the app or the ROKU. I have a regular streaming subscription and we only use this device. I also made sure to look through the phone app that only the ROKU connects to the streaming service from our account. PLEASE HELP!

New Poster

 • 

1 Message

2 y ago

This is happening on all three of my Roku devices and I agree that it's annoying.  Here are my Roku models:

 

Streaming Stick 3600R

Streaming Stick 3800R

Streaming Stick+ 3810R

ComcastChe

Official Employee

 • 

6.1K Messages

2 y ago

Hi @abchezold, and @swoodey

 

Thank you for posting to the Xfinity Forums. I apologize for the experience you're having with your Roku devices. I'd like to do some troubleshooting to help resolve this. In order to begin, I will need the following information in a private message: 

  • Your first and last name 
  • The MAC Address of your modem 

To send a private message click on my name "ComcastChe", then click send a message. 
 

Regular Visitor

 • 

2 Messages

2 y ago

This happens on my Roku Ultra too (several of them).

 

Very aggravated.

 

ComcastChe

Official Employee

 • 

6.1K Messages

2 y ago

Hi abchezold, 

 

If you're still having issues, please send me a private message and I can continue to investigate. 

New to the Community?

Start Here