Meehan2382's profile

Regular Visitor

 • 

3 Messages

Wed, Jan 15, 2020 6:00 AM

Xfinity Stream Beta on LG TVs does not work

Hello,

 

I recently signed up with Xfinity and was excited about the ability to stream Live TV without having an actual cable box.  I got the stream app set up on my mobile device and Samsung TV, however when I put the app on my two LG TVs, the Live TV is basically unwatchable.  I worked with Comcast to trouble shoot and they even had a tech come out to try and fix it, but it is still not functioning.  The video is all choppy and the audio is in and out.  This is only happening on my LG TVs.  I was just wondering if this is a problem with the app and is it going to be fixed soon?  I don't want to go out and buy a Roku stick for a Smart TV since that is the entire reason I bought a smart TV in the first place.

 

Thank you

Responses

jav6joev

Bronze Problem Solver

 • 

2.1K Messages

1 y ago

What model LG TV do you have and where did you get the Xfinity Stream Beta app?  When I go to LG Content Store on my LG 43LF5900 there is NO Xfinity Stream app (regular or Beta) available.

Regular Visitor

 • 

3 Messages

1 y ago


@jav6joev wrote:

What model LG TV do you have and where did you get the Xfinity Stream Beta app?  When I go to LG Content Store on my LG 43LF5900 there is NO Xfinity Stream app (regular or Beta) available.


I have 2 different LG TVs.  Not sure on the model at the moment, but both TVs had the beta app in the LG store.

jav6joev

Bronze Problem Solver

 • 

2.1K Messages

1 y ago

My LG TV is older and the Xfinity Stream app probably isn't supported.  I've encountered this with other apps and my other smaller LG TV's.

Regular Visitor

 • 

3 Messages

1 y ago


@RobertWy wrote:

I assume you read this?

https://www.xfinity.com/support/articles/activating-xfinity-stream-smarttvs


Sure did.  Also worked with a tech for a couple hours and then had an additional tech come out to the house.  No resolution.  I am just hoping one of the app developers sees this so they can find out what is wrong with the app on LG TVs.

New Poster

 • 

1 Message

1 y ago

I am currently tangling with the same issue. Both my LG 50 " TV's have decided to not load the app as of a few days ago. The app has worked fine up to that time. 8 mos. actually. They say they are working on it. I have back tracked to my Roku units which work flawlessly. Stay tuned.

laugustus

Frequent Visitor

 • 

8 Messages

1 y ago

I have the same issue on my lgtv.  Comcast - any ETA on when this will be resolved?

Rustyben

Expert

 • 

24K Messages

1 y ago


@laugustus wrote:

I have the same issue on my lgtv.  Comcast - any ETA on when this will be resolved?


what model number is your LG tv? did you download the app directly from your TV's software store?

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick
laugustus

Frequent Visitor

 • 

8 Messages

1 y ago

Yes - I downloaded it from the lg tv store

New Poster

 • 

1 Message

1 y ago

I know it's not the answer your looking for but the SD channels work fine. I've got 2 TV's that are on the model list and every HD channels just sits there skipping and buffering but if your in a pinch there's always the SD channels.

New Poster

 • 

1 Message

1 y ago

It looks like 2 separate issues in this forum. I was able to see all my channels for months than the LG app stopped working completely. It just asks me to check my network settings. I deleted it to redownload and still the same message. Wont let me login again. Its the app that is having issues. Who do we talk to about this? Xfinity or LG?
Rustyben

Expert

 • 

24K Messages

1 y ago


@Atinom6688 wrote:
It looks like 2 separate issues in this forum. I was able to see all my channels for months than the LG app stopped working completely. It just asks me to check my network settings. I deleted it to redownload and still the same message. Wont let me login again. Its the app that is having issues. Who do we talk to about this? Xfinity or LG?

you might try resetting the LG to factory specifications then installing the app again.  after the reset be sure to power unplug the television from AC for 30-60 seconds after it resets.

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New Poster

 • 

1 Message

1 y ago

hello

 

Any solution to the issue on the LG TV just staying on the Welcome screen on the Beta version?  I cannot select the Get Started Button and it stays on the screen ..

 

Thanks

 

Regular Visitor

 • 

1 Message

1 y ago

I am having the same issue and I'm not sure what the problem is.  I have the LG webOS TV UM7300PUA.  When I click on the "Get Started" button after installing the app on the tv, nothing happens.  

New Poster

 • 

2 Messages

1 y ago

I am having the same problem, I have LGwebOS on my OLED TV and the app freezes on the welcome screen so when I click on the get started button nothing happens the app is frozen. On Roku the app works but not on my LG TV and my TV is supposed to work. I called xfinity and spoke to three tech the last was a level 3 national rep and they told me it was an LG firmware issue. I am on the latest firmware for my TV. They don’t appear to be looking at fixing this issue and seemed surprised that I was having it despite the fact I showed them several web threads reporting the same problem. One person claimed they fixed this by plugging their tv into the Ethernet cable directly from the modem and setting up the app and then they were able to get Wifi to work. I would need a 60 foot Ethernet cable to do this or to carry my tv to another room. If anyone gets a fix to this issue please post. Also it would be helpful if someone confirms that the direct connection to Ethernet cable works before I take my tv off the mount or buy a massive cable. I am currently back to using Roku xfinity app but Roku 4 is terrible, no volume control, you can’t turn it off without navigating a million menus and it crashes all the time. If only they had an Apple TV app.
Rustyben

Expert

 • 

24K Messages

1 y ago

check to see if your TV's firmware is up-to-date. unplug TV for 3 or so minutes and plug back in. uninstall the app and re-download it from the TV's App store and sign in. be sure to accept the terms and conditions or the app will not function.

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New to the Community?

Start Here