Jarekeja's profile

Regular Visitor

 • 

1 Message

Fri, Sep 25, 2020 12:00 PM

Xfinity Stream Beta app on LG OLED stopped working

I have been using the Xfinity Stream Beta on two LG OLED smart TV's,  for several months. it stopped working yesterday. I've tried several fixes, uninstalled the app, reinstalled it, checked the network, unplugged the TV.  Now when I try to a open the app the screen goes black and it says "Loading". 

Responses

Rustyben

Expert

 • 

24K Messages

5 m ago


@calzat wrote:

The fix you put in place clearly does NOT work unfortunately!  Comcast, you never communicated what the fix actually was that you tried.  It seems you have fixed it for some users possibly because you did something to maybe reset their accounts, but the underlying issue is still there!  It was working for me for a while and it just stopped working.  I am now getting the infamous "This device can only access Xfinity Stream on your in-home Xfinity network" and I'm on my in-home network.  C'mon Comcast, how long will it be before this issue is resolved that so many users have clearly complained about?

 

I will provide a few more details on what I have and what I've tried and this includes everything every forum response has on this issue.  I have wasted my entire day on this so far.  I have an LG TV with WebOS.  The app was again working fine.  There were a few changes on my account that are of interest.  For one, I got rid of my Xfinity internet and phone and only kept my Xfinity TV because after 5 months of working with Xfinity on the internet issue I had, they could not fix it.  When I finally gave up and went to another internet provider, my internet issue was fixed literally the first day that I received my new service.  This issue is not because of my new internet service because the stream app currently works fine on all of my iOS devices on this same network that my LG TV is on.  I also changed my username since I had transferred my account from my mom who passed away to myself (same address and everything).

 

I have tried not only deleting the app, unplugging the TV, re-installing, etc. roughly ten different times, I also even did a complete factory reset several times on my LG TV (which frankly wastes more of my time since I have to set everything else back up now).  Even a LG TV factory reset did not resolve the issue.  The app still does not ask for me to sign a new Terms of Agreement.  I also as suggested went in and created a whole new Xfinity user that is linked on my account since it was mentioned that was one "workaround" until the app is fixed.  That workaround did not work either.  I paired my TV with the new code using the new username and password when it asked me to verify on my browser and that did not work.

 

There is nothing else I can think of to try and this is beyond frustrating.  I also noticed that every time I try to download the Xfinity Stream Beta app on my LG TV, it still says it was last updated on 4/20/2020.  So how would this issue be fixed in the app if for over 8 months now there has not been one single update to the app is my wonder?

 

I have got rid of my Comcast internet and TV because of lack of support and functionality simply not working.  I am now on the verge of getting rid of my Comcast TV service as well for this same fundamental reason unless this issue is resolved.  It is pointless to call customer service since none of them even remotely have the skillset to resolve literally any issue I have asked of them to resolve for me.  Typically I'm in a worse situation after I call them than if I didn't call them at all.

 

Please Comcast, help us resolve this issue permanently.  Sorry for the frustration, but we just want your service to work.  Thanks!


for account settings diagnosis, does a smart phone/tablet and a PC work normally? do you have a roku or firestick that can run the stream TV beta app?

New to the Community?

Start Here