user2020's profile

Frequent Visitor

 • 

12 Messages

Fri, Sep 18, 2020 8:00 AM

xfinity Stream app

Hi. I hope this is the right place to ask about the issue I have been having for months with my xfinity Stream app on my phone. I been seeing an error message every time after logging in, then going to Live TV > Favorite Channels, and then clicking on any of them. The error message that pops up says :

 

We're sorry. This video stream is not playable under the current device conditions. Please disconnect any external devices (including HDMI, screen mirroring, or casting devices) and try again.

 

I don't understand why this has been going on. I do not have any external devices connected. I'm using the app on phone.

Responses

Rustyben

Expert

 • 

24K Messages

9 m ago


@user2020 wrote:

Hi. I hope this is the right place to ask about the issue I have been having for months with my xfinity Stream app on my phone. I been seeing an error message every time after logging in, then going to Live TV > Favorite Channels, and then clicking on any of them. The error message that pops up says :

 

We're sorry. This video stream is not playable under the current device conditions. Please disconnect any external devices (including HDMI, screen mirroring, or casting devices) and try again.

 

I don't understand why this has been going on. I do not have any external devices connected. I'm using the app on phone.


you may have a mirror app running, or be out of the usa or a vpn in use?

user2020

Frequent Visitor

 • 

12 Messages

9 m ago

A mirror app? Not really. I don't have VPN either.

Rustyben

Expert

 • 

24K Messages

9 m ago


@user2020 wrote:

A mirror app? Not really. I don't have VPN either.


on what device are you streaming?

user2020

Frequent Visitor

 • 

12 Messages

9 m ago

I'm streaming from my Moto Z2 Play phone.

user2020

Frequent Visitor

 • 

12 Messages

8 m ago

Still having the error message. Anyone have any idea? I need to have this fixed asap.

user2020

Frequent Visitor

 • 

12 Messages

8 m ago

Well that did not help. Still the same error message. This is ridiculous. Why isn't anyone fixing this?

user2020

Frequent Visitor

 • 

12 Messages

8 m ago

Am trying a downgrade which I downloaded, to a version from last year to see if the problem persists.

user2020

Frequent Visitor

 • 

12 Messages

8 m ago

Is the outage a known issue with Android/iOS phones as well? I have not been able to watch anything for months on my Moto Z2 Play 😞

Rustyben

Expert

 • 

24K Messages

8 m ago


@user2020 wrote:

I'm streaming from my Moto Z2 Play phone.


have you updated your android OS? are you on Pie or 10?

 

edit: moved your off-topic cross post reply to your own thread.

user2020

Frequent Visitor

 • 

12 Messages

8 m ago

Hi, yes I updated Android some months ago to Android Pie 9.

Rustyben

Expert

 • 

24K Messages

8 m ago


@user2020 wrote:

Hi, yes I updated Android some months ago to Android Pie 9.


try updating to the now available android 10?

user2020

Frequent Visitor

 • 

12 Messages

8 m ago

I can't upgrade to Android 10, in fact I checked for availabilty to do so for Moto z2 Play, and it has no more updates. They will not have Android 10 on it.

Rustyben

Expert

 • 

24K Messages

8 m ago


@user2020 wrote:

I can't upgrade to Android 10, in fact I checked for availabilty to do so for Moto z2 Play, and it has no more updates. They will not have Android 10 on it.


go to your settings app and clear the cache for the stream app (close app first). google for directions if needed. then uninstall the app. power down the phone and then restart and reinstall the app. sign in and accept the terms and conditions. working now?

user2020

Frequent Visitor

 • 

12 Messages

8 m ago

Been there done that. Nope.
Rustyben

Expert

 • 

24K Messages

8 m ago


@user2020 wrote:
Been there done that. Nope.

if it is backed up, a full factory reset of the android device might fix it.

New to the Community?

Start Here