A

Visitor

 • 

4 Messages

Sat, May 14, 2022 12:20 PM

Xfinity connects to chromecast. Says ready to cast but does not show program

I have seen many many posts to this forum particularly labeled 7 months ago and 5 months ago. All of them are now labeled closed but there was never a solution provided. Xfinity responded saying they are working on it and even gave the day it would be resolved yet users posted that it's still not working after those dates. Both the sfinity stream app on my mobile devices as well as xfinity.com on my laptop recognize and connect with chromecast. The TV then says ready to cast. The cast icon is full which shows they are connected. Then an image for the program will show on the screen even the Program Title. 3 dots also appear showing it's trying to cast. However those 3 dots never go away and the program does not display. Chromecast works with all my other video apps and websites just not Xfinity. Oddly one day I was able cast from xfinity.com to the TV on my laptop but then it went back to the 3 dots and no program. I have rebooted chromecast, reset chromecast, deleted the xfinity app and reinstalled, made sure app is up to date on devices and chrome is up to date on my laptap. NOTHING WORKS and from what I see Xfinity just blows smoke does not give a real answer as to why and does not provide a solution

Official Employee

 • 

252 Messages

Hace 10 d

@AvalonUser

Hello and Good Morning! Thank You for taking the time to reach out to Xfinity Support, here on the Community Forum. I was super happy when the Xfinity Stream App became available for casting to Chromecast. I will be happy to assist you.

The instructions for casting are here - https://comca.st/3sCLe6o

To be sure, all devices in the process meet the minimum requirements for Chromecast devices, and all Eligibility and Requirements listed at the bottom of the above page?

https://comca.st/3sCkSS9

Visitor

 • 

4 Messages

@XfinityTravis​ Don't you think I have been through every help page Xfinity has to offer???? Do you think your consumers are unintelligent and don't know how to troubleshoot? Don't you get that the people posting here know how to cast and giving the instructions as an answer to a software issue...is treating us like we are imbeciles? Most of the people having this problem is that it had been working and suddenly stopped or it works with all other apps yet not Xfinity. Doesn't that already tell you that we and I already know how to cast. So why send instructions on how to cast as the solution?

I have also scoured the internet for solutions, which led me to this forum. On it I have found SOOOOOOOOOOOOOOOOO MANY people with the exact same issue and not in a single post including this has Xfinity offered any viable solutions other than pat and generic answers such as the one given above...attempting to give the appearance of caring and helpfulness but in the end not providing anything that is actually useful, even remotely helpful and not even close to a solution. So let me lay it out for you. I have TOP OF LINE equipment, ALL minimum requirements are exceeded, and eligibility met. All apps are up to date. Yet your service is not working. 

Visitor

 • 

4 Messages

Additionally, there was ONE DAY I was able to stream several shows from Xfinity on my macbook pro to the TV. It worked well...then suddenly never again...same TV, same Chromecast, same computer, same Xfinity website. And it has NEVER Worked on my iPad Pro 

Visitor

 • 

4 Messages

Another thought to share with you...regarding how ridiculous it is sharing a link on how to cast was even an option your thought to share...is that if you read the post clearly. It explains how the app and website say they are connected and casting...yet the 3 dots showing is connected never stop displaying...so obviously how to cast is not an issue. Please if you want to provide customer support post info that actually supportive and addresses the issue posted. Not just the basic generic answer Xfinity has been posting over and over that hasn't solved this ongoing issue

Official Employee

 • 

252 Messages

Hey there, @AvalonUser

Our Community Forum was designed to build a positive and thriving peer to peer help community. As your post is a new topic thread (not the first, but new), we are obligated to provide some basic instruction for all to see.

I would like to take a moment to remind you of our first Forum Guideline - Be good to each other. “Positive, constructive comments will help to maintain the positive spirit on these forums. Please give the same consideration and tolerance to others that you would like to receive from them.”

If you have questions about our forum guidelines, you can find our guidelines here -

https://forums.xfinity.com/conversations/guidelines/xfinity-forum-guidelines/602da8fdc5375f08cd20b38c

[Edited: "Link Added"]

Please also keep in mind that the ability to cast from either the Xfinity Stream App or the Xfinity Stream portal is provided as a courtesy in addition to your subscription services.

I appreciate you confirming that your equipment meets the minimum requirements and is up to date. Let us take a closer look at you account, try a few things, and get a ticket created, if needed, OK?

To get started, could you please send our team a direct message with your full name and full address?

To send a "Direct Message" message:

  • Click "Sign In" if necessary
  • Click the "Direct Messaging" icon at the top of the page (looks like a text bubble)
  • Click the "New message" (pencil and paper) icon
  • Type "Xfinity Support" in the "To:" line and select "Xfinity Support" from the drop-down list which appears. The "Xfinity Support" graphic replaces the "To:" line
  • Type your message in the text area near the bottom of the window
  • Press Enter to send it

(edited)

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick
forum icon

New to the Community?

Start Here