comvictim's profile

New Poster

 • 

1 Message

Sat, Sep 5, 2020 3:00 PM

Xfi app keeps asking me to upgrade, gives me an error when I try, won't work without it

I just got a  Xfi Gateway self-install kit. I installed the Xfi app for iOS, but it immediately told me "To access xFi, you'll need to upgrade your service/equipment.” There are no other options in the app to proceed beside "Upgrade now." I click through to do it, sign in, verify my address (it has two in the system, one is my old one) and proceed. It tells me "You have the latest equipment," but suggests I can upgrade anyway. I click upgrade because it's the only option. Inevitably I hit the same error: "We're sorry. It looks like you'll need some help managing your equipment. Please contact us and one of our friendly and knowledgable representatives can help."

 

I contacted a friendly and not very knowledgable representative, who walked me in circles on the phone for over an hour, suggested that she needed to connect me with someone who specialized in the Xfi app, put me on hold for five minutes, then disconnected the call. She was able to manually set up the SSID and password for me, but I can't change it without the app, which always brings me back to the "Upgrade now" screen and is therefore useless.

 

People in threads like this seem to have experienced the same error and resolved it with the help of someone at Xfinity. Maybe someone more competent than the tech I talked to on the phone is reading and can help resolve it for me.

Responses

toohip4u

Frequent Visitor

 • 

18 Messages

9 m ago

I've having the same issue on my Xfinity Stream app on my Amazon Fire Stick.  It keeps telling me there's an update available.  I follow the update, and it tries to go to Amazon app store, and says "unavailable" for Xfinity upgrade.  Now it's giving me unfamiliar error issues claiming it can't read my Xfinity app on my SD car on my fire box. 

Xfinity must of pushed some update through, and it's affecting us Xfinity subscribers using streaming for our Xfinity programming on some TVs.  What's going on and how do we resolve this?

New to the Community?

Start Here