U

Friday, November 17th, 2023 1:26 AM

Advance Security

I just had my wifi updated and I can't enable advance security. It goes in a loop but never turns on. 

Official Employee

 • 

1.3K Messages

5 months ago

Hello, @user_lohgx1. Are you trying to access Advance Security through the Xfinity app? Have you attempted these steps?
1. Enable it from Overview.
*If you don’t have Advanced Security enabled, tap the card on the Overview prompting you to turn it on.
*Tapping the card will walk you through turning it on.
2. Enable it from the Security tab.
*If you don’t have Advanced Security enabled, you’ll see a light blue box at the top of the Security tab prompting you to turn it on.
*Tapping Turn it on will walk you through turning it on.
*If you don’t see the option at the top of the Security tab, you can also turn it on by scrolling down and selecting Advanced Security.

Contributor

 • 

53 Messages

@XfinityGabby​ 

I have the same problem as lohgx1 has. I don’t think you understand the situation. If your above steps are followed, it’s just goes in a loop and never turns on, from the prompt in the blue box, it just loops back to the blue box after the systems attempts to turn it on with the screen that flashes, “it may take up to 10 minutes for changes to take place” that screen flashes for a millasecond and then goes back to the blue box. It’s seems this is an engineering fix that needs fixed ASAP, we’d like to know our networks are protected! This has been an ongoing issue that’s persist if you search the form here, I myself have had this problem a couple times in the last couple years or so. 

Official Employee

 • 

744 Messages

@skyfox23 We know the importance of being able to use Advanced Security, and definitley want to ensure that you can get the support you need on this! I can see that there have been a few comments left on different threads for this issue. In the future, please avoid creating multiple comments/post for the same issue to help follow our Acceptable Use Policy


Can you please share more about what step is failing for you? 

(edited)

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Contributor

 • 

53 Messages

Please read my comment above. I don’t feel

like going in circles with Admin or Mods on this forum…the step itself is what’s failing me! This just needs a ticket open for engineering to fix it, no one on here seems to understand what customers are telling you guys…it won’t turn on! There’s only one way of telling you that! 

forum icon

New to the Community?

Start Here