TigerJr's profile

Contributor

 • 

47 Messages

Wed, Mar 24, 2021 3:15 AM

X1 HD DVR Clock Wrong

Hi, I noticed recently that the DVR clock is slow by 3 minutes. Is there anyway to fix this or re-sync to current time?

thanks!

Responses

andyross

Silver Problem Solver

 • 

6.9K Messages

3 m ago

Just wait awhile and it will get a bit better. X1 has ALWAYS had a horrible on-screen clock time. I typically see it 20-40 seconds slow at best. For a device tied to talking to servers for everything, it's amazing it can't keep the clock in sync.

If you seem to have issues, you can do a simple restart (hit "A" key then choose restart). It will help, but even then it usually is no better than the typical 20-40 seconds off.

I think since the 127.0.1 software update (go to settings, then scroll all the way down to About), it has gotten much worse. It's not unusual to see it 90+ seconds off now.

Tcalg

Problem Solver

 • 

179 Messages

2 m ago

I would just like to second this comment.  The slow X1 clock is very annoying.  It doesn't affect recordings, but it affects things like reminders and guide data.  Rebooting the box can sometimes get the clock as close as 20 -30 seconds slow, but within a day it can drift back to nearly three minutes slow.  An internet-connected device syncing itself to network time servers should not be more than a second or two off.

Visitor

 • 

1 Message

1 m ago

I've had this issue with both the DVR and the standard boxes for over a year, even though I've changed out the hardware more than once.  Right now, the clock display on my DVR box shows the correct time, but the clock on the onscreen guide is showing the time is nearly 3 minutes earlier.  A previous unit was 3-4 minutes off and meant shows would start recording late and I'd missed the first minute or two, had to set all recordings to start early.  If I do a system refresh or restart, it will sometimes (but not always) make a partial correction to the onscreen guide time although the two clocks still do not match up, at best they are off by 1 full minute.  I reported this to Comcast and they said they'd send it to technical support for review, but that was over 1-1/2 months ago and there's been no reply.  Since there's no way to manually adjust either the clock display time or the on-screen guide time, it's quite annoying. 

New to the Community?

Start Here