BensonFam's profile

New Poster

 • 

2 Messages

Fri, Apr 3, 2020 3:00 PM

Upgraded Service - Can't view "new" channels?

We recently upgraded our service and received a self-install kit for a new modem and a new DVR X1 Box. 

 

Installing the modem and the internet service is fine. But, when I attempt to watch the "new" channels on my new Cable Box, they are unavailable. 

 

I've spoken to two Comcast customer agents. The first indicated that they would "reset" my cable box and the problem would resolve in 1-2 hours. Unfortunately, it did not. 

 

The second agent I spoke to did a system refresh of my cable box and said the channels just "take a really long time to load" so it could take as much as 24-48 hours to see my new channels. 

 

It's been more than 48 hours and still no change. 

 

Connections are checked. Everything looks good. Again, I can see all the channels from the previous "starter" package. 

 

Examples of channels I can not currently see are CNN, Disney, ESPN, and HGTV. 

 

Error code I continue to see is: XRE-03121 

 

Thanks for any help you can provide. 

Responses

New Poster

 • 

2 Messages

1 y ago

We recently upgraded our internet and cable plan. This upgrade included a new X1 DVR, a new Modem, as well as significantly more channel options. After installing all the equipment successfully, I am able to view all of the channels from my previous "starter" package, but can not yet view channels from my new upgraded package. 

 

Examples of channels that I can not view currently are: ESPN, HGTV, Disney and CNN. 

 

I've spoken to two separate Customer Service Agents. The first told me that they were "resetting: my new cable box and my new service should be up and running in 1-2 hours. No dice. 

The next day, another agent I spoke to said that they were also resetting the box remotely. (I watched this happen, so something was going on.) That agent said it could take as long as 24 hours to see changes. It's been now more than 48 hours and still no changes. 

 

I've checked all my connections, and my "new" internet modem seems to be performing fine. 

Should I just continue to wait or is this indicative of a larger problem? 

Thanks! 

Rustyben

Expert

 • 

24K Messages

1 y ago


@BensonFam wrote:

We recently upgraded our internet and cable plan. This upgrade included a new X1 DVR, a new Modem, as well as significantly more channel options. After installing all the equipment successfully, I am able to view all of the channels from my previous "starter" package, but can not yet view channels from my new upgraded package. 

 

Examples of channels that I can not view currently are: ESPN, HGTV, Disney and CNN. 

 

I've spoken to two separate Customer Service Agents. The first told me that they were "resetting: my new cable box and my new service should be up and running in 1-2 hours. No dice. 

The next day, another agent I spoke to said that they were also resetting the box remotely. (I watched this happen, so something was going on.) That agent said it could take as long as 24 hours to see changes. It's been now more than 48 hours and still no changes. 

 

I've checked all my connections, and my "new" internet modem seems to be performing fine. 

Should I just continue to wait or is this indicative of a larger problem? 

Thanks! 


it is not normal. would you try using a smart phone/tablet and the xfinity stream TV app and see if the channels work from that device? (edit: combined your cross-posts)

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New to the Community?

Start Here