malcolmjr's profile

Regular Visitor

 • 

2 Messages

Thu, Jan 30, 2020 9:00 AM

Screen flicker intermittent new X1 box

A few weeks ago I got a new X1 box installed, lately I’ve noticed that sometimes when displaying solid colors they flicker. The problem is intermittent and there seems to be no pattern. I have tried switching to a new HDMI cable and a different HDMI input. The problem doesn’t occur on my Apple TV, only on Comcast input so i assume it is an issue with the video source. Can anyone offer me advice or input as to why this is happening and what I should do? Thanks

Responses

cdm777

Frequent Visitor

 • 

5 Messages

10 m ago

Unfortunately, I have no advice on how to fix this, but am dealing with the same issue for at least over a year now. Whatever I am watching on my X1 4K box there is a random flicker. I've confirmed it's the box as well, as my tv apps have no issues, and I've tried multiple hdmi cables, plus previous Xfinity box did not have the issue. I can only assume I need to get a new box, but would love to hear anyone elses input.
Rustyben

Expert

 • 

24K Messages

10 m ago


@cdm777 wrote:
Unfortunately, I have no advice on how to fix this, but am dealing with the same issue for at least over a year now. Whatever I am watching on my X1 4K box there is a random flicker. I've confirmed it's the box as well, as my tv apps have no issues, and I've tried multiple hdmi cables, plus previous Xfinity box did not have the issue. I can only assume I need to get a new box, but would love to hear anyone elses input.

What is the name of the HDMI port (embossed in the plastic of the TV)? did you try moving to HDMI 1 or HDMI 2 on the TV to see if the problem changes?

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick
cdm777

Frequent Visitor

 • 

5 Messages

10 m ago

Thanks for the response. I'm actually running my hdmi from the X1 box to a receiver and then out from the receiver into the hdmi (arc) input on my tv. Unfortunately, I was dealing with the issue before this setup when the X1 was connected directly to the tv and using different input. I've already tried different variations bypassing the receiver and using different inputs and cables, but still no luck.
Rustyben

Expert

 • 

24K Messages

10 m ago


@cdm777 wrote:
Thanks for the response. I'm actually running my hdmi from the X1 box to a receiver and then out from the receiver into the hdmi (arc) input on my tv. Unfortunately, I was dealing with the issue before this setup when the X1 was connected directly to the tv and using different input. I've already tried different variations bypassing the receiver and using different inputs and cables, but still no luck.

there's the problem.  Connect the set top box to the TV's HDMI 1 or HDMI 2 port. then HDMI from ARC (from TV) to HDMI input on the receiver. This will fix any HD 4k UHD etc issues alswo. ARC is 'audio return channel' from TV to sound system. 

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick
cdm777

Frequent Visitor

 • 

5 Messages

10 m ago

Appreciate the response once again, but that's not the issue. I'm using the arc input on the TV from the receiver so the tv can return the audio from the apps on the TV back to the receiver. Anyway, as I mentioned, I've already tried bypassing the receiver and hooking up the X1 box directly to other inputs on the TV and the issue still persists.
Rustyben

Expert

 • 

24K Messages

10 m ago


@cdm777 wrote:
Appreciate the response once again, but that's not the issue. I'm using the arc input on the TV from the receiver so the tv can return the audio from the apps on the TV back to the receiver. Anyway, as I mentioned, I've already tried bypassing the receiver and hooking up the X1 box directly to other inputs on the TV and the issue still persists.

ARC is for digital audio return to send audio from the TV to the receiver/soundbar. It is not hooked up correctly. Cable box to HDMI 1 or HDMI 2 (check owner's manual for correct one for 4k UHD input).

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New Poster

 • 

1 Message

10 m ago

Do you have the new smaller cable box? Ours flashes to a black screen. Sometimes it's once, sometimes it's 10xs. Other times it says no cable. It's just cable TV. All the streaming channels work. We thought it was our new TV but its the new cable box we have. We can't connect to it to restart or check it from our account. Says it can't find it. All the cables are fine and securely connected but if you move or shake the box it will work.
cdm777

Frequent Visitor

 • 

5 Messages

10 m ago

I have the Arris XG1v4 box. It's the smallish 4K DVR box. Unfortunately, my issue actually doesn't sound quite as bad as yours. We only have just a slight flicker, primarily on the right and lower side of the screen (when looking at the tv). However, it applies to all output from the box, whether it's cable, Netflix, Amazon, 4k content, YouTube, anything we watch has the slight flicker.
cdm777

Frequent Visitor

 • 

5 Messages

10 m ago

Thanks for the response once again, however, what you're suggesting would in turn involve doing all the video/audio switching using the tv instead of the avr. This is not ideal and not how things should be hooked up, or at least it defeats the purpose of the features incorporated into the modern avr.

Like I mentioned, I'm confident the issue is with the box, and at some point I'll get around to getting a new one. I suppose I was hopeful there was some magical reset feature, setting, or keystrokes that I was unaware of that resolved the issue.

New Poster

 • 

1 Message

9 m ago

I recently had the same problem. I have a 2 year old non-smart tv. But it has a HMDI2 (arc) connection. Problem solved!

Regular Visitor

 • 

2 Messages

8 m ago

Lower the resolution on the X1 box to 1080 and it will go away. For some reason Xfinty broadcast is to slow to be processed by a 4k TV.

New Poster

 • 

1 Message

5 m ago

Hi you'all have the same exact situation.  Upgraded recently to 4k TV Sony X900H 65" and almost immediatly experienced this thing.  freaked out a bit wondering if my big purchase was a bust but also came to the conclusion it was xfinity and not the TV.  I probably have a first generation X1 box and wonder if a newer one would fix it but kindof of worried to go there because right now its tolerable but an occasional annoyance nothing more.  Will try reducing the output from the box to 1080p to see if that helps.  Never tried that but seems counterintuitive and desireable to dumb down my box so the TV doesn't flip out.  Would be best if xfinity came out with a fix.

Visitor

 • 

1 Message

Did this fix it? I just bought a new Samsung 4K UHD and the screen goes black in the middle of shows and then comes back on. Just dumbed down the 1080 adjustment to see if that works. Tx

Official Employee

 • 

343 Messages

5 m ago

Thanks so much for taking the time to reach out to us regarding your video issues. I very much appreciate your patience and greatly apologize for the delay in our response. I know how important the services are to your home and we want to do all that we can to assist. I can only imagine how it would feel to have a brand new tv and suddenly have a picture issue with your Tv programming. I would love to get to the bottom of the service issues Can you please reach out through private message with your first and last name, name on the account if different, service address and account number? If you’re having trouble locating this information, you can also reference our world-class MyAccount app to view all of your account details by the simple touch of your fingertips! Please follow the process here to learn how to obtain that information: comca.st/30x1qW2. 

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New to the Community?

Start Here