mfleckus's profile

New Poster

 • 

1 Message

Sun, May 31, 2020 1:00 PM

Re: Xfinity remote won't pair both TV and receiver

I have the same or similar issue.  I can pair to my TCL Roku and the remote turns off my TV (and controls the TV volume).  As soon as I also add a Receiver for audio control, the "off" button no longer turns my TV off.  It only turns my Receiver off.

 

Responses

Official Employee

 • 

2.5K Messages

1 y ago

Hi, mfleckus. Thank you for posting here! Are you following the on-screen prompts when pairing the remote, or are you doing it manually without them?

Regular Visitor

 • 

5 Messages

1 y ago

I have the same issue. Appears that numerous folks have the same pairing Issue. I’ve even had Comcast techs out to the house and they can’t fix it. Comcast isn’t addressing the problem.
Sparty1966

Frequent Visitor

 • 

24 Messages

7 m ago

The on screen prompts do not help.  You program just the tv and all power works fine.  The second you program a receiver, the all power button only works for the receiver yet the tv power button still works for the tv.   So the programming looks like it thinks the TCL tv's are an audio receiver. 

Sparty1966

Frequent Visitor

 • 

24 Messages

7 m ago

Just set up my TCL Roku TV and similar issue.   The all power button only turns off the receiver.  So I have to hit all power, then tv power to turn the tv on.   Double check the code list and try them all.  It suggested what mine was most likely going to be but it wasn't.   Had an LG tv and both worked together fine.  If I set up the TV only the all power works fine.    I see reports of this from over a year ago with no fix.  You would think for $200 a month they could figure this out? 

Regular Visitor

 • 

5 Messages

7 m ago

I was able to get the power on/off between Roku, Sony TV, Cable & Yamaha receiver to work however .... it will change channels but not volume. Xfinity claims my TV & receiver are too old for their updated systems. Four years isn’t too old to me. I could throw it out & buy new if my xfinity bill wasn’t so high for the basic. 🙄

Visitor

 • 

2 Messages

2 m ago

I am having the same problem with the new voice remote, problem is there is not a TV power button on the new voice remote so I still need to use the TV remote to power the TV on and off if I want to control the receiver with the X1 remote.  I have an Onn Roku TV and a Sony Receiver.

Visitor

 • 

2 Messages

I should add that the TV input button on the new X1 voice remote works for the TV, just not the power all button.

Visitor

 • 

1 Message

1 m ago

I just switched from Dish network to Xfinity and am having the same problem with my TCL-Roku tv and Yamaha receiver. Won’t turn the tv off, only the receiver. The remote that Dish Network provided worked just fine with my equipment. My tv & receiver are only 3 years old. There is no reason why Comcast-Xfinity can’t figure this issue out for what we are paying for. Has anyone figured out a fix for this yet? 

(edited)

New Poster

 • 

2 Messages

11 d ago

I have the same issue.  I picked up a new remote when I swapped out some of my equipment.  The new remote will only program either my TV or my receiver. I followed the on screen prompts to first pair with my TV then it asked me if I wanted to pair with my receiver. As soon as I paired with the receiver, it would no longer control my TV. Whichever device is paired last, works.  I do still have my old remote which is identical to the new one and it controls both just fine. 

Official Employee

 • 

91 Messages

Thank you for taking time out of your day to reach out to us here on our forums, @JSW72! Since this thread is over a year old, please create a new submission so we can assist you there. I appreciate your understanding and look forward to helping you with the remote pairing. 

New to the Community?

Start Here