niceguy44's profile

Visitor

 • 

3 Messages

Thu, Jul 8, 2021 2:54 AM

Pixel issue

There seems to be an intermittent pixel and sound issue on my tv and appears to only be on the USA channel. I have already tried checking all HDMI plugs and all connections, reset DVR box, reset and unplugged Xfi box and did a complete system reset. Still the same issue. Any suggestions? 

Accepted Solution

BruceW

Gold Problem Solver

 • 

23K Messages

4 m ago

Pixelation and loss of sound happens when the signal for the channel you are trying to watch is too weak or has too much noise. This might be because of a bad cable box or a problem at Comcast (check https://www.xfinity.com/support/status/, 1-800-Comcast voice response, or the "My Account" app) but is most likely due to a poor connection between the box and Comcast's network, usually in or near your home.

Troubleshoot by checking all connectors for corrosion and tightness, and by looking for damaged coax cable. Running the cable through a surge protector, a defective splitter, or too many splitters can cause signal problems as well. If there is an amplifier in the line make sure it's getting power.

If you can't find the problem or you'd rather have Comcast take care of it, call them at the phone number on your bill or 1-800-Comcast, or use one of the options on https://www.xfinity.com/support/contact-us/. Ask them to check the account setup and send a refresh signal to the box. If they can't fix the problem remotely, insist they send a tech out to identify the cause and correct it.

If the tech finds bad coax, splitters, amplifiers, or connections in your home (even if Comcast originally supplied them) you'll probably have to pay for the visit unless you have their Service Protection Plan (https://www.xfinity.com/support/articles/service-protection-plan, closed to customers that don't already have it). If the trouble is due to a faulty Comcast cable box/DVR/digital adapter or anything outside your home, you shouldn't be charged.

(edited)

Visitor

 • 

3 Messages

@BruceW Thank you for your help I have already tried everything so I guess it’s time to call Comcast

Official Employee

 • 

439 Messages

4 m ago

Hello, @niceguy44, thanks for working with us on forums and for doing all you can to troubleshoot by checking your HDMI cables, resetting your DVR and checking all connections. I apologize for the poor picture and sound on the USA channel. I know when an issue only affects one channels it's a head scratcher and frustrating. Especially if you really like this channel! When you have a moment, you can use the chat icon on the top right corner to send a "Peer to Peer chat to "Xfinity Support." If you can include your name and service address this will be perfect. Once we have your account, we can check your signal levels and schedule an appointment as needed. 

Visitor

 • 

3 Messages

@ComcastJosephB I’m not seeing how to peer to peer chat with you but nothing seems to fix the pixel and sound issue I am having only with the USA channel 1403

Official Employee

 • 

317 Messages

I can help you find the Peer to Peer Chat!

 

To send a Message:
1. Click on the Chat Bubble icon in the upper right corner to access our new Peer 2 Peer feature!
2. Search for "Xfinity Support" and select "Xfinity Support" from the drop down list.
3. Type your message in the text area.
4. Press Enter to send!

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

1 Message

1 m ago

I had alot of pixel problems etc trying to watch the cup race saturday night at Brisotl on NBCSN.  Can someone tell me what I can do to fix these problems? I also has trouble trying to watch the Pats game yesterday on CBS ????

Official Employee

 • 

554 Messages

Hello and thank you for taking the time to reach out to us here on our Xfinity Forums. I can appreciate how frustrating it is when you just want to enjoy a game only to have video issues. There's a few things you can do to attempt to resolve this on your one. You'll want to check that the coaxial connection is secure between the wall plate and the cable box. Check that the HDMI cable is secure between the box and the TV. If you are still having issues you can log into your Xfinity My Account app, select cable and then troubleshooting. You'll be able to send some signals to your cable box directly through the app. Have you already tried these steps with no resolution?

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

9 Messages

1 m ago

I have pixelation issues for 2 months before they finally fixed it. It took 3 techs coming to my home. They ended up just about rewiring my home and even did some work on the pole. They fixed that and then the "echoing" started. It was all on Rally South Sports 401 channel. It only happened every few commercials. 3 months later and 2 weeks ago, they put in a ticket to the national support center and I was told they were getting some engineers to look into it. One tech even told me to get a new TV..haha...But now I know I'm not crazy because other people in my area have been experiencing the same thing. It's quite odd that it's only Rally Sports and during live events that the commercial "echo". 

New to the Community?

Start Here