U

Saturday, September 23rd, 2023 5:55 PM

Closed

Paramount+ very sluggish when using the Xfinity box

Streaming Paramount+ through the Xfinity box is almost unusable -- very, very, very sloooooow. Takes forever to load content; constant circle/loading/freezing while streaming. I've tried the recommended power off/on, restarts of the cable box, modem and TV and uninstall/reinstall of app ... to no avail.

I have no issues whatsoever when streaming to my Mac mini, which is ethernet-connected. So I am almost sure that the issue is the streaming from the Xfinity box through the HMDI cable to my TV. (Tried a different HDMI cable too.) I suppose that I could verify this by removing the ethernet cable from the Xfinity box and connecting it to my TV (and removing the HDMI cable from the TV), but what's the point? If I do that I might as well get rid of the box, right?

I have the Choice TV package (primarily for the local broadcast channels) and Connect More (200 Mb internet speed). Also, of the other streaming apps that I subscribe to (Apple TV+, Hulu, Max, Netflix, Peacock, Prime), only Peacock exhibits some of the slowness that I see with Paramount+ (but where Paramount+ is a 9.5 on the slowness scale, Peacock is about a 2, so liveable). All of the other apps stream the actual content just fine after the initialization of the app, which is typically very slow (likewise, exiting the stream or app is also very slow).

Any suggestions? TIA

Official Employee

 • 

1.1K Messages

7 months ago

@user_b028d5 I understand the frustration you would feel with a slow connection and trying to stream something, and I am sorry that you have been having this issue. Our Connect More speed is great for up to 6 devices active online at a time. It also works great for streaming, but you would see a bit of an issue if you have more than one device attempting to stream. Can you see how things are if that is the only thing using your internet network?

6 Messages

Thank you for following up.

I do not normally stream on more than one device (my LG OLED TV). I streamed on the Mac mini just to see if I could replicate the problem on another device (I could not). I do have more than six devices connected to my network. However, the other devices are not streaming. And all of the other devices (except for the Mac mini and the X1 box) are wirelessly connected.

Please note that although Paramount+ is the only one of my streaming apps that has the painfully slow (buffering?) problem or simply stops streaming altogether, streaming the other apps is typically very slow when initializing, exiting, or changing content. That is, streaming the actual content in the other apps works well but starting, stopping and navigating around the apps can be frustrating.

Official Employee

 • 

655 Messages

This is great context, thank you so much. You mentioned the other apps being slow during certain actions - are these also being accessed via the X1 box, or via the TV app menu?  If accessed via the TV App menu, does this provide a better experience or more of the same?  During these periods of slowdown or partial freezing via the X1 box, are there any error messages or codes that are shown?  

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

6 Messages

The other apps are being accessed via the X1 box -- so, I click the Xfinity button on the remote and then select the app from the list, which is arranged horizontally across the screen, beginning with Peacock (and ending with Paramount+). The experience is the same (slow during certain actions) for all apps. I don't recall seeing any error messages, but I will check later today to be sure. 

Note that (only) for Apple TV+ I usually pick that app from the LG main menu. That is, I don't even go in to the X1 box. I simply power on the TV, the LG Home Screen appears and instead of picking the Connect to X1 Box option, I pick the Apple TV+ app and begin streaming that. The experience is wonderful -- stunning picture, no lags, no problems.  

Official Employee

 • 

655 Messages

Gotcha! Figured we'd ask those more broad questions as well just to see if the issue is present in other mediums on the TV also. If you are seeing any error codes or messages these can help point to any known errors we can help resolve whatever may be going on. 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

6 Messages

No error codes or messages. In the case of Paramount+, a seemingly endless wait (with that circle thing, and sometimes just a blank screen). I usually just give up and exit the app.

1 Message

3 months ago

My xfinity internet speed is 800Mbps and paramount plus still sluggish. When watching on my Samsung phone I have no problem. Just on TV through x1 box

Problem Solver

 • 

1.3K Messages

@user_dr6mw4 Hi there, let's take a closer look at this. Please send us a direct message with your full name and service address. 

Here are the detailed steps to Direct Message us:
• Click "Sign In" if necessary
• Click the "Direct Message" icon (upper right corner of this page)
• Click the "New message" (pencil and paper) icon
• Type "Xfinity Support" in the to line and select "Xfinity Support" from the drop-down list
• Type your message in the text area near the bottom of the window
• Press Enter to send your message

I no longer work for Comcast.

1 Message

2 months ago

I have been having ongoing issues with the paramount+ app through Xfinity X1. So slow loading content list and then error message when attempting to play content “uh oh, an error has occurred but we’re working on fixing it. We’ll be up and running again shortly “ this error message displays for every program or movie I attempt to watch! I’ve tried to restart, unplug, etc. Finally got it working. But then the next day same error messages. Paramount+ works fine on my other tv with Roku on works on my phone and iPad with no issues. Only problem is through X1 box which is extremely frustrating.

Official Employee

 • 

1.7K Messages

Hello, @user_fr09n4! We are happy to help with the Paramount+ issues. We want things to work great and are happy to help! Have you tried sending a system refresh signal to the box? You can do that by saying "system refresh" to the voice remote, clicking on the "A" button and then to the right on the menu to the signal, or by typing system refresh into the Xfinity Assistant. How long has the issue been happening? 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

1 Message

2 months ago

I have the same issue.  If it is not resolved im canceling my subscription 

Official Employee

 • 

1.1K Messages

Hello @user_x47kbp, thanks for reaching out for help with your Paramount+ App. Can you please go into more detail on the issue you are experiencing? Things like they type of device you are using, if you are having trouble on one device or all devices, and any steps you have already taken to try and resolve the issue. 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

6 Messages

2 months ago

An update ...

I resubscribed to Paramount+ so that I could test with another setup. Different (smart) TV (app) with OTA antenna, same ethernet connection. No issues at all with Paramount+. I then changed the network connection from ethernet to wireless. When using WiFi, I could definitely tell the difference when starting and navigating (browsing, searching, exiting) the app and when beginning to stream content. However, after getting the stream going, I could not tell much difference between the ethernet and WiFi connections.

My conclusion is that the Paramount+ app is a total bandwidth hog to initialize and navigate but once the stream starts, outside of Xfinity, is ok. So I wonder what is going on with Xfinity? I would have thought that after I selected the Paramount+ app from the Apps menu, Xfinity would get out of the way and the Paramount+ app would grab the WiFi connection to do its thing, which should be ok, as above. Now I am wondering if instead, all of the Paramount+ traffic runs through the Xfinity box, which could be the reason for the delays and buffering issues. Who knows?

1 Message

2 months ago

This thread is mind numbing.   Paramount + works awful on xfinity.   Just slow and almost unusable.   It's obvious to me that xfinity knows this and has just trained their reps to ask incredibly basic questions to act engaged.    If i was paramount, I'd be furious.   As i am, for wasting so much time. 

Official Employee

 • 

1.1K Messages

Hi there @user_2mp7ib! Thank you so much for reaching out to us on our Community Forums page. I am sorry to hear you are having troubles with the Paramount + App on your X1 box. You are in the right place and we would like to take a look at this issue for you.

Please send us a direct chat message with your full name and complete service address to “Xfinity Support”. To do so, click on the chat icon located at the top right of this forums page.

Here's the detailed steps to direct message us:

  • Click "Sign In" if necessary
  • Click the "Direct Message” icon (upper right corner of this page)
  • Click the "New message" (pencil and paper) icon
  • Type "Xfinity Support" in the to line and select "Xfinity Support" from the drop-down list
  • Type your message in the text area near the bottom of the window
  • Press Enter to send your message

 

Let me know if you have any questions.

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Frequent Visitor

 • 

9 Messages

2 months ago

Paramount+ works perfect on my main Xfinity box. Very sluggish on the other remote boxes (X1?)

Official Employee

 • 

744 Messages

@TheBleedingEdge  I am glad to hear that this app is working well on your main box, we want to ensure it is working like that across all boxes! How many other boxes are you seeing this app run slow on? What is the TV Box Model of the one(s) you are having issues with?

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

New Poster

 • 

2 Messages

Same problem here in Staunton Va. very sluggish to load Paramount + content. Commercials are slow too. 

Official Employee

 • 

957 Messages

@hoebe Sorry to hear about the trouble with Paramount+. Have you tried any troubleshooting? A good modem restart always ensures your service has the latest updates. You would ensure all coaxial connections are secure and finger tight. Then you would unplug the box from the electrical outlet, and wait 30 seconds before plugging it in again. Once your internet connection is back up and running, you would do the same with each of the cable boxes to make sure they are up-to-date as well. This will clear up most issues. If it doesn't, just let us know. 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick
forum icon

New to the Community?

Start Here