U

Visitor

 • 

1 Message

Wed, Sep 29, 2021 4:31 AM

Guide and Menu delay and latency

The menu and guide take several seconds to load.  It take several second to move the cursor within the menu; channel input from the menu takes several seconds.  There is too much latency.

The remote works perfectly: power on/off; volume … no latency.

The problem is with the Comcast menu and it’s reaction time.

hwkn

Contributor

 • 

60 Messages

2 m ago

I'm having the same problem with the guide also........it's hard to use the guide with this problem going on......I ended up doing a system refresh which  fixed it at least for now.

(edited)

Official Employee

 • 

314 Messages

Hey there @hwkn! I am glad this resolved the issue for you. Please do not hesitate to reach out if ever needed! 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick
XfinityChe

Official Employee

 • 

6.2K Messages

2 m ago

Hi @user_341cf8! We appreciate you for posting, and sharing your experience. I know how frustrating this can be. I've experienced it once before. From what I've seen before, latency can be caused by poor signal levels, or noise on the line. I'd like to start by checking your signal levels to see if we need to get a tech out for premise issues. Can you send a direct message with your first and last name and service address? To send a direct message click the "Direct Messaging" chat icon in the top right corner of the page, then click on the pen and pad icon and enter "Xfinity Support" in the "To" section of the chat.

New to the Community?

Start Here