John1455's profile

Contributor

 • 

29 Messages

Tue, Sep 7, 2021 1:18 PM

Firmware update from June 2020 still NOT WORKING

This was posted to the forum by Comcast in June 2020: "A firmware update was recently deployed to TV Boxes that may be causing picture issues for some customers. The update includes a feature that defaults TV Boxes to the highest screen resolution the TV is capable of. This is causing a black screen, blue screen, a 'no signal' messages, or a "flickering" screen for some customers."

The temporary fix was turning OFF Prefer Best Available Resolution option. I left it this way until this issue was fixed. It's been almost a year now and I decided to turn back on the Prefer Best Resolution option thinking almost a year would be plenty of time to fix this bug but found that this issue was NOT FIXED and causes my TV to lose audio, cause screen to flicker, and finally become white snow.

Responses

XfinityJoeB

Official Employee

 • 

6.9K Messages

1 m ago

Hello John1455. Thank you for exploring our Forums and for creating a post. I can assist in getting an Advanced Repair ticket opened for you so our team can look into getting this fixed for you. Please reach out to us via direct message and send your full name and service address to Xfinity Support. To do so, click on the direct message icon located at the top right of this forums page. Let me know if you have any questions.

 

Here's detailed steps to send us a message: 

 • Click "Sign In" if necessary

 • Click the "direct message" icon (upper right corner of this page)

 • Click the "New message" (pencil and paper) icon

 • Type "Xfinity Support" in the to line and select "Xfinity Support" from the drop-down list

 • Type your message in the text area near the bottom of the window

 • Press Enter to send your message

John1455

Contributor

 • 

29 Messages

@XfinityJoeB 

Unable to follow these instructions because a screen keeps popping up to tell me to complete my registration whenever I attempt to sign in. When I try to proceed I am told the email address is already being used and to use another one. Of course it's being used! I'm using it!! My registration had been completed years ago. The screen acts like I am registering for the first time. I am NOT.

XfinityJoeB

Official Employee

 • 

6.9K Messages

Apologies you're experiencing troubles with the direct message. Is there any chance you have a different web browser you can attempt the sign in on? 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

New to the Community?

Start Here