U

Visitor

 • 

1 Message

Wed, Apr 13, 2022 10:54 AM

Extremely slow response of X1 Box to remote commands

I have had X1 Box with voice remote.  Recently, the response has been extremely slow.  I have reset the box, the remote.  I have changed the batteries, and I have checked the connections.

R.Vicini

Contributor

 • 

75 Messages

6 m ago

Since all x1 remote control commands are handled through the internet, you may have a poor signal to said box. 

Visitor

 • 

1 Message

5 m ago

I have the same problem and this is not the only forum for this same complaint.  The moderators seem to close the complaints when they get too many.  In one of the prior forums, someone suggested using system refresh from the A button.  I tried that and it did work.  But I also tried the whole take-the-batteries-out-of-the-remote fix that has you do that then randomly press all the buttons to make sure none of them are stuck.  (They weren't.)  If this refresh fix holds true to form, the problem will grow back again shortly.

Someone on one of the other forums complained that this service is a bit pricey for such sluggish service.  Couldn't agree more.  Instead of spending time answering complains on forums and then closing forums when they become too embarrassing, they should fix the problem. 

Worse, this particular box stops holding a pause on a recorded item after 10 minutes.  That is patently absurd and likely a sign of a generally flimsy quality of service.  I've had xfinity before and it was never this bad.

XfinityRay

Official Employee

 • 

838 Messages

Thanks for reaching out about the X1 remote, @Gattochat. I am glad that the System Refresh seems to have fixed the issue. Please let us know if the sluggishness returns so we can take further steps. When your cable box is not holding a pause for more than 10 minutes what happens? Is it sending you back out to the program information or a TV program?

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

1 Message

5 m ago

I found a video on YouTube that works!!! Take the batteries out, press every single button. Just go on from top to bottom. Replace the batteries and voila! Apparently on the remote the buttons get stuck and are confusing the box.

I went weeks with my new box aggravating the hell out of me. I’m glad I found the little (and easy) fix! I also want to mention I have the weird remote where the arrow buttons in the middle are flat. I’m sorry I don’t know what model it is. It’s new though. Hope this helps!!

Visitor

 • 

1 Message

@user_94bcdb​ I can’t believe this fix worked for me. Thank you!

forum icon

New to the Community?

Start Here