condor33's profile

New Poster

 • 

1 Message

Wed, Mar 10, 2021 6:00 AM

All X1s in home freezing continuously

Many channels freeze for about 3 to 5 seconds continuously on all boxes. Had a refer to maintenance submitted & is was traced to head end. Issue resolved for about a day & now still occurring.

Responses

ComcastJoeTru

Official Employee

 • 

6.7K Messages

2 m ago

Hello condor33. We appreciate you visiting and posting on our Forums. We're sorry you are currently experiencing trouble with your X1 service. I can assist with troubleshooting and diagnostics for your X1 boxes. To get started, please send me a private message and include your full name and service address, so I can assist you. Send me a private message by clicking my profile name (ComcastJoeTru), then click "Send a message". 

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New Poster

 • 

1 Message

2 m ago

Hi, I’m having the same problem. Is there an easy fix ?

Official Employee

 • 

74 Messages

2 m ago

Hi, @Jhana! Thanks for reaching out to let us know you're also experiencing the cable box issue. Please send a private message with your name so we can further assist. To send a private message, please click my name "ComcastBianca" then select "Send a Message" on the right side.

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

Visitor

 • 

2 Messages

20 d ago

Why can’t Xfinity fix this? They keep saying it may be local to the account, the splitter, or cable, or whatever. If SO MANY people are having the same issue, don’t you think the issue is on Xfinity-owned equipment?  It’s like their signals are just not strong enough. However, it affects customers randomly — different channels it seems, but always the HD channels. Can somebody explain definitively what’s going on?  This has been happening for at least a couple of years, and some, like me, have had the problem go away for months and then come back. 

CCAndrew

Diamond Problem Solver

 • 

25.9K Messages

Have you ever had a tech out or any other troubleshooting or just live with it? The boxes are sensitive to needing a clean signal. Channels come in on different frequencies at different locations and majority of  people watch HD channels over SD channels. For issues that go away and come back, it could be weather related. 

New to the Community?

Start Here