requa's profile



125 Messages

Saturday, April 22nd, 2023 12:22 AM


30-Second Skip Stopped Working

Crisis time! Years ago, I learned how to reprogram the Xfinity remotes to make the Page Up and Page Down buttons yield 30-second skips instead of the default 5-minute skips (exit-exit-exit-0030). Tonight, this is no longer working. I have tried reprogramming multiple times with this sequence and have tried with both the older and newer models of remote. I did recently perform a System Refresh with my X1 box trying to restore a flaky Netflix app. How do I restore this useful option?

Accepted Solution



125 Messages

8 months ago

And just like that, crisis averted. I think I got my remotes working properly again. I tried manually forcing my remote back to the 5-minute default even though it was already doing that (exit-exit-exit 0500), testing, then programming again for the 30-second option (exit-exit-exit 0030). ow it is giving a 30-second skip again, and the correction is even working with the other older remote without having to reprogram each of them.

Bronze Problem Solver


571 Messages

Hi, requa I know how much I love using the 30-second skip to fast-forward through commercials! I am happy to hear you were able to get it fixed. 


I no longer work for Comcast.



1 Message

@requa​ Thanks for posting. This is a lifesaver. Worked for years and today it quit on me. 

Regular Visitor


5 Messages

Even better than the 30 second skip is just using your voice to "skip ahead ____" or "jump forward_____" any length of time you specify. 30 seconds, 2 minutes, whatever. 

forum icon

New to the Community?

Start Here