U

Visitor

 • 

2 Messages

Sat, May 14, 2022 6:16 PM

I can sign in to my account but after that nothings loads for me

Basically title, once i sign in and at the home page. Nothing loads its either "communication went wrong" "credentials are invalid" or "just try again".

I can't go to account setting, cant make purchases or literally anything thats account related. I try use different browser, on my phone that all end up the same for me.

XfinityJorge

Official Employee

 • 

334 Messages

13 d ago

Hello, @user_611013 thanks for contacting our Xfinity Support Team over our Forums. We are sorry to hear about you not being able to log in and we are here to help you get access. In order to get started, can you please send me a private message to Xfinity Support with your full name and full address by clicking the chat icon in the top right?

Visitor

 • 

2 Messages

@XfinityJorge​ Hi, I can't find your name in the chatbox

XfinityJorge

Official Employee

 • 

334 Messages

Thank you so much for the quick response @user_611013 and I hope your Saturday is going well. No worries I will send you the detailed instructions to send us a private message below. 

 

Detailed steps to direct message us:

• Click "Sign In" if necessary

• Click the "Peer to peer chat" icon (upper right corner of this page)

• Click the "New message" (pencil and paper) icon

• Type "Xfinity Support" in the to line and select "Xfinity Support" from the drop-down list

• Type your message in the text area near the bottom of the window

• Press Enter to send your message

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick
forum icon

New to the Community?

Start Here