jmb1996's profile

New Poster

 • 

1 Message

Tue, Jun 30, 2020 12:00 PM

Closed

Account Activation/ No Confirmation Email for Service Order

Hello,

 

I recently ordered internet service for self-installation at the place I am moving to next month. However, when I finished my purchase I received no confirmation email with a receipt or anything with any information on my account or how long it will take to "set up" my account.

 

All my current Xfinity account says is:

"Thanks for your purchase, _ _ _ _ _!

We're getting your account set up. Check back soon to track and activate your services."

 

I'm also not able to change my service or view my bill or account settings without running into error messages. How long does the account setup process usually take and when will I be able to review my purchase and account settings? I just want to make sure that my order went through and is confirmed to arrive on or around when I scheduled it. 

 

Thank you in advance and best wishes.

 
 
 

Official Employee

 • 

839 Messages

1 y ago

Hi there @jmb1996 , I just private messaged you. Cheers!

Regular Visitor

 • 

2 Messages

1 y ago

I am having the same problem. Can I also get a dm please?

Official Employee

 • 

839 Messages

1 y ago

DM'ed @Drdreidel 

Regular Visitor

 • 

3 Messages

1 y ago

I also have the same problem. Can you DM me as well?? Just signed up yesterday.

Official Employee

 • 

839 Messages

1 y ago

Hi @bheidel1 

 

I just took a look and you seem to be up and running, your account is active, your My Account is accessable (just checked in my agent view of your account). Feel free to PM me if you're seeing otherwise. 

New Poster

 • 

1 Message

1 y ago

I also have the same problem so I have no way of knowing my account number. The only thing I have received so far is my order confirmation. Can I also get help?

New Poster

 • 

1 Message

1 y ago

I too ordered service online on 7/8. I have recieved no confirmation emails and have had no luck trying to contact customer service. I see they authorized my CC for $50. I also ordered expedited shipping for my self install kit. I have not recieved the self install kit or any indication that my service is active.

 

When I log in all I get is the "

Thanks for your purchase, Gary!

We're getting your account set up. Check back soon to track and activate your services."

 

Please help.

Official Employee

 • 

839 Messages

1 y ago

@GCOPP43 PMed!

New Poster

 • 

1 Message

1 y ago

Can I get a PM about this too? I've had the same screen for months.

New Poster

 • 

1 Message

1 y ago

Same problem here. Can I get some help?

Official Employee

 • 

839 Messages

1 y ago

@echo514 @Jonwhang  I've sent you PMs. 

 

Note: please check your messages and get back to me.

New Poster

 • 

1 Message

1 y ago

I also have the same problem @ComcastJonathan . Could I get help?

Regular Visitor

 • 

1 Message

1 y ago

@ComcastJonathan Can i get help with this as well? Signed up for service today and credit card was charged but received no confirmation email.

New Poster

 • 

1 Message

1 y ago

@ComcastJonathan Please help, happened to me as well.

New Poster

 • 

2 Messages

1 y ago

@ComcastJonathan I’m having the same problem, can you please PM me as well?

New to the Community?

Start Here