gh837291's profile

Visitor

 • 

2 Messages

Fri, Oct 15, 2021 5:03 PM

RDK-03117 error

I've had the flex device for a few months with no problems.  Now I keep getting the RDK-03117 error.  I've reset the modem and checked all the connections.  I've restarted the flex device.  No other computer or streaming device on my network has any problems except the flex device.  It is connected via ethernet as it is too far from the modem to connect via wi-fi.  But it worked on ethernet for the past few months with no problems until now.  Should I get a new flex device?

Official Employee

 • 

582 Messages

3 m ago

Hi, @gh837291 [Edited username to remove PII]. It sounds like you are taking the right steps here! That error usually means there's a connection issue on the internet side. Since you checked the connections, can you confirm that the cables are finger tight? Also that the power cord of the modem is plugged into a wall outlet rather than a power strip or switched outlet? The ethernet cable would work, but since you are having issues, are you able to try a different ethernet cable? 

(edited)

Visitor

 • 

2 Messages

@XfinityChristina Sorry it took so long to get back to you.  I followed your advice and replaced the ethernet cable between the flex device and the wall connection.  Since I have done that, I've had no problems with the connection.  A bad cable must have been the problem.  Thank you.

Official Employee

 • 

664 Messages

We are so happy to hear that everything was resolved with that cable replacement. If you need anything else in the future, please feel free to create a new thread here on Xfinity Forums! We are always here to help 24/7 and we look forward to you being part of the Forums community! Have a wonderful rest of your day! 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

New Poster

 • 

6 Messages

3 m ago

I replaced my older non-4K system with new X-1 system with 1 main box and 3 satellites. Main box is fine and all satellites are not non-working reporting RDK-03117 error.

Working system for almost a year then the other night the satellites went down......I have unplugged power to all units.....powered up main box first verified I have Xfinity TV then one by one powered up the satellites....and each one came up with Welcome screen....the three moving dots, then dot froze in middle...screen went black....waited 10 minutes and hit Xfinity bad on remote to get the "We're sorry" message and I selected "try again".....after 30 minutes 1 satellite came alive for less than 5 minutes before going dark....click Xfinity bad on remote...RDK-03117 error......

Powered off Modem / Router, Main box and all units and restarted the procedure......Modem reposts 300+Mbps (rocket ship) on Xfinity Speedtest.....then power up main box (got Xfinity TV) and then satellites one by one and no joy.....same behavior.I have already spent 3 hours on the phone as well as chat with Xfinity support......I guess it is time to call and have repair come out.

Never had this problem before switching out for 4K capable system......

Official Employee

 • 

509 Messages

Hello, @Katmann. I know you've tried a few steps already, but I can certainly do everything I can to help. I ask that you reach out privately, so we can cover the details of your account. You can start by clicking the chat icon located in the top right corner of your forums page when signed in. Once there, you can search for "Xfinity Support" to compose your direct message. Please add your first and last name to help us locate your account. Let me know if you have any questions along the way.

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

New to the Community?

Start Here