U

Monday, November 20th, 2023 11:17 PM

peacock premium no longer active

I have Xfinity Gig+ speed internet and for a while I've had access to peacock premium because of it. Randomly today I no longer have to peacock premium and now peacock prompts me to subscribe to premium to watch anything. I went to xfinity.com/xfinityassistant/ and clicked on the 'activate now' prompt under peacock but got an invalid request error. According to the FAQs, this is because I've already activated it, which is true I have. However, for some reason no matter what or where I sign in on, peacock no longer recognizes that I have premium. 

Official Employee

 • 

1K Messages

5 months ago

Thanks for reaching out, user_lbpmn6! Have you already tried to clear cache and cookies as well as uninstall/reinstall the peacock app?

 

1 Message

5 months ago

Same here. I just signed up for xfinity again after moving and the Activate link for peacock is invalid. I tried installing the app on my phone and it still doesn't work. 

Official Employee

 • 

463 Messages

@user_e2lh8z, thank you for reaching out and using the Community Forums page. I would be more than happy to assist you with your Peacock related concerns. Have you previously had access to Peacock in the past and now that access is gone?

 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick
forum icon

New to the Community?

Start Here