U

Visitor

 • 

1 Message

Friday, January 6th, 2023 11:13 PM

Closed

Apple TV not loading

I just got a flex box and am trying to get Apple TV to work. I can launch the app and it displays the Apple TV logo but then goes black and never gives me the option to log in. I have restarted the flex box and that does not work. How do I get Apple TV to work on this?

Visitor

 • 

1 Message

11 months ago

Exactly same issue and customer service clueless 

Official Employee

 • 

1.4K Messages

@bebik22. We are full service here and can help! I show one workaround to try is :

 

Current workaround as per Apple:
1. Log in to Apple TV on macOS, IOS
2. Windows user can log into Apple TV at https://tv.apple.com
3. A Terms & Conditions prompt will show up. Accept the T&C.
4. Log in on the Xfinity STB.(Flex)

 

If that doesn't work then puttiung in a ticket on your account is the next best step. Let me know. 

I no longer work for Comcast.

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Problem Solver

 • 

954 Messages

11 months ago

Hello @user_257707. I am sad to hear you are not able to load the Apple TV app on the Flex box. I would like to get your account pulled up and see about getting this resolved! Please send me a direct message with your first and last name, along with your complete service address to “Xfinity Support”. To do so, click on the chat icon located at the top right of this forums page.   

Here are detailed steps to direct message us:  

  • Click "Sign In" if necessary 
  • Click the direct message icon
  • Click the "New message" (pencil and paper) icon 
  • Type "Xfinity Support" in the to line and select "Xfinity Support" from the drop-down list 
  • Type your message in the text area near the bottom of the window 
  • Press Enter to send your message 

Visitor

 • 

2 Messages

10 months ago

My new Sony Bravia (65A80K) does not stream Apple TV+. I have an Xfinity Box (XG1v4-A) linked to a Yamaha RX-V4A AV receiver that is linked to the TV. Both links using ultra high-speed HDMI rated 4K 120p. 

It looks like it is loading and then black screen. I received Apple error message N163D742F6 at one point which is a "can't find the network" message. Bravia indicates ethernet is active.

Also, TV and Yamaha are on Ethernet. I've also tried disconnecting all ethernet but that didn't work.

All other streaming apps work beautifully. Apple TV+ works on my other Xfinity box.

Help me Xfinity. Multiple tech support calls got nowhere.

Official Employee

 • 

232 Messages

Hello, @user_50e681. We would be happy to help with your Apple TV issues. 

Could you please send our team a direct message with your full name and full address?
To send a "Direct Message" to Xfinity Support:
Click "Sign In" if necessary
Click the "Direct Messaging" icon
Click the "New message" (pencil and paper) icon
The "To:" line prompts you to "Type the name of a person". Instead, type "Xfinity Support" there
 - As you are typing a drop-down list appears. Select "Xfinity Support" from that list
 - An "Xfinity Support" graphic replaces the "To:" line
Type your message in the text area near the bottom of the window
Press Enter to send it

I no longer work for Comcast.

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

2 Messages

10 months ago

Hmmm. I have the same issue but I don't have the Flex Box (I have the XG1v4-A)

Do you have a Sony Bravia? Or a Yamaha AV Receiver? My gut tells me it's a compatability issue with one of the two.

Visitor

 • 

2 Messages

10 months ago

Is there any resolution? Apple TV works on my DVR box but none of the other 4k flex boxes. It displays the Apple logo and then it goes black.

New Poster

 • 

5 Messages

10 months ago

Hope this helps for you…

  1. Click your Xfinity button on your remote.
  2. Navigate to the settings icon all the way to the right.
  3. Scroll down to Privacy and select it.
  4. Scroll down to Locally Stored Data and select it.
  5. A message will appear asking you to Clear local storage. Select OK.
  6. Close out and relaunch the app.

(edited)

Visitor

 • 

2 Messages

@greatgazoo​ That worked. Thank you!

Visitor

 • 

1 Message

this worked for me too

Visitor

 • 

1 Message

@greatgazoo​ did not work for me

Visitor

 • 

1 Message

@greatgazoo​  This worked for me too. Thank you 🙏🏼 

Visitor

 • 

1 Message

This worked for me too...thanks for the info. 🤓👍

Visitor

 • 

1 Message

10 months ago

This worked for me too! I returned 2 flex boxes thinking it was a bad app. I also spent 2 days with Xfinity tech support and they had no notifications on this problem. Glad I found this forum and this solution. However, I'm not understanding why tech support is not aware of it. They should be notified to better serve customers who call in with this problem. 

Visitor

 • 

2 Messages

9 months ago

My Apple TV 4K wont load the shows via Xfinity internet.  Just like my Xfinity internet wont allow Dish anywhere to load.  This violates the contract. 

Visitor

 • 

1 Message

9 months ago

That absolutely worked!  Thank you so much.  Xfinity support still does not know how to fix this issue.  They continue to claim no one has contacted them about this issue. 

Visitor

 • 

2 Messages

9 months ago

Is clearing local data going to delete all my login info for other apps (netflix, etc)?

Visitor

 • 

3 Messages

@user_a8fa84​ some will need to be signed into again. Not all. 

New Poster

 • 

2 Messages

9 months ago

just exchanged our box now Netflix and Apple TV won't load

Visitor

 • 

3 Messages

8 months ago

This will solve your issue

  1. Click your Xfinity button on your remote.
  2. Navigate to the settings icon all the way to the right.
  3. Scroll down to Privacy and select it.
  4. Scroll down to Locally Stored Data and select it.
  5. A message will appear asking you to Clear local storage. Select OK.
  6. Close out and relaunch the app.

Visitor

 • 

1 Message

7 months ago

I’m also having issues with launching the Apple TV app. When I launch it, it tells me that I need new equipment. Why would I need new equipment to open an app?

Official Employee

 • 

842 Messages

It sounds like I will need to see what equipment is specifically on the account and potentially send you some new equipment, @user_77a965. Will you please send our team a direct message with your full name and full address?
~~~~
To send a "Direct Message" message:
• Click "Sign In" if necessary
• Click the "Direct Message" icon
• Click the "New message" (pencil and paper) icon
• Type "Xfinity Support" in the "To:" line and select "Xfinity Support" from the drop-down list which appears. The "Xfinity Support" graphic replaces the "To:" line
• Type your message in the text area near the bottom of the window
• Press Enter to send it

I no longer work for Comcast.

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick
forum icon

New to the Community?

Start Here