BlueFire127's profile

Frequent Visitor

 • 

6 Messages

Sat, May 9, 2020 7:00 PM

Emails sent to comcast.net addresses getting dropped but not bounced

Hello, just trying to get the attention of someone from Comcast support to look into this. I use a domain with a ".email" TLD, so mydomain.email because all the normal .com .net TLD's were taken. The mail service is hosted by Mailfence which is a paid service, not a cheap/free solution. I have an SPF record correctly setup for my domain to help limit spoofing, no issues there. My email works great for emailing just about anyone, with 100% success I can email:

  • Gmail
  • Yahoo
  • Outlook.com/hotmail
  • and a wide variety of .com addresses such as local businesses

In all the above cases my emails land in recipients inboxes, never flagged as spam.

For some reason, people with comcast.net email don't receive my emails:

  • They don't go to the Inbox
  • They don't go to Spam/Junk
  • They don't get filtered or hit a rule that's moving or deleting them
  • I have never received a bounced email back with a reason

Many of my family members use their comcast.net email addresses which is how I found the problem to begin with and did some troubleshooting. The only thing I can think of would be that comcast at one point detected spam being sent from the same IP as the mail server since it's a hosted provider, meaning I'm not the only domain hosted there and maybe someone else's hosted email domain was compromised or spamming, however no other email service is rejecting my mail (sent from Mailfence), it only appears to be Comcast. Perhaps @CCAntiSpam could take a look? Pleeeeease and thank you! A DM or email to me would be fine and I can share the domain with you to help with your search.

 

Responses

Accepted Solution

Frequent Visitor

 • 

6 Messages

8 m ago

I committed a cardinal sin... I posted a problem I had on a forum, and then once I found the solution I didn't come back to post it! My apologies. Anyway, in my last comment I said I was going to implement DKIM and DMARC for my domain since it's a good thing to have anyways. I can confirm that once I did that my mail issues with sending to comcast.net users was resolved. No more missing emails getting dropped entirely instead of bounced (which should NOT be happening Comcast... if it's rejected for any reason it deserves to be bounced so mail admins like us have some idea what's going on), and no more being delivered straight into the spam folder on the rare occasion the email did go through. I've now sent probably 40+ emails to comcast addresses since and haven't had a single issue.

 

@WBLIBAdmin - I think this is your answer (assuming you were in fact having the same issue I was)

 

The lesson here is for whatever reason, even though it's not required by Gmail, Yahoo, Outlook.com, etc, if you want your email to make it to comcast.net Inboxes; your domain's, IP's, and individual email's good or perfect spam scores are completely irrelevant. In addition to SPF you MUST also have DKIM (and possibly DMARC) established for your domain. This is obviously not the global standard for handling email, but it is the comcast standard apparently.

 

@ComcastCSAEmail - Please spread the word. If you happen to see similar posts in the future, let them know Comcast requires SPF, DKIM, (and DMARC?), for mail to even have a chance of being accepted. It would be even better if this somehow got added to a FAQ for hosts or providers. i.e. "My emails don't seem to reach comcast.net users but everyone else is getting them just fine and my spam scores are perfect, what's going on?".

BruceW

Gold Problem Solver

 • 

22.6K Messages

1 y ago


@BlueFire127 wrote: ... Perhaps @CCAntiSpam could take a look? ...

That ID is no longer active in the Forums. @ComcastCSAEmail is now handling the kind of questions you are asking.

Official Employee

 • 

583 Messages

1 y ago

feel free to PM me the domain so i can investigate further.

Frequent Visitor

 • 

6 Messages

1 y ago

Just sent a PM. Thank you for checking into this.

Official Employee

 • 

583 Messages

1 y ago

@BlueFire127 i'm only seeing a single email sent to our server in the last 30 days. The single email sent was delivered into the spam folder. Would you happen to be getting a bounceback message?

Frequent Visitor

 • 

6 Messages

1 y ago

@ComcastCSAEmail - No unfortunately I haven't gotten a single bounceback. Just now I tried emailing my own comcast address and I did receive it in Spam. Then I added myself as a contact (name@mydomain.email) waited several minutes and sent another, it still went to Spam.

I guess that means Comcast's spam filtering does not take into consideration if you have an address saved in your contacts that it shouldn't be spam. There also doesn't appear to be a 'whitelist' option anywhere in the menu for users to quickly mark it as such. I tried the "Not Spam" option in the context menu and all it does is move the email from Spam to Inbox, but future emails from that address continue to go to spam. It's looking like the only user accessible option to correct this would be creating a Filter Rule for emails from my address, which is... not a good solution.

It would be helpful if you'd be able to tell me why my emails are flagged as spam by Comcast's filter (but not by Gmail, Yahoo, or others); is the cause the domain name, sending IP, or content?

Frequent Visitor

 • 

6 Messages

1 y ago

I'm now adding DKIM and DMARC for the domain, it's good to have anyways, but I don't know if that'll have any affect on the 'reputation' of the domain as it's already clean.

Regular Visitor

 • 

2 Messages

8 m ago

I work for a public library, and we are also experiencing the same issue. Our domain is wblib.org, we use GSuite for Nonprofits for email. Audit logs show successfull deliveries:

Nov 24, 2020, 09:00	0.47 seconds	
Delivered to an SMTP server with IP address: 2001:558:fe16:1b::15 (TLS enabled)

 But the patron does not receive the message in their inbox, spam, etc. We have had multiple patrons complaining about this issue and it's impacting our (opt-in) notices, as well as things like registrations for virtual programs. We have only received complaints from patrons with comcast.net email addresses.

 

@ComcastCSAEmail is this something that you can look into? Thank you.

Official Employee

 • 

98 Messages

7 m ago

@BlueFire127 

 

Hello,

 

Comcast does NOT require any of those for proper delivery. We have located the issue via the domain which was being filtered for spam as well. This has now been removed at this time. 

Regular Visitor

 • 

2 Messages

7 m ago

@BlueFire127 thank you for the update. We did have SPF properly configured but I went ahead and configured DMARC/DKIM in mid-December as well, in attempt to fix the issue. Your post in May led me down that path, so it (hopefully) helped regardless of the followup!

 

@ComcastSPAAbuse Have you looked at our (wblib.org) domain as well? I am still being told that patrons with Comcast email accounts are not receiving emails. 

Frequent Visitor

 • 

6 Messages

5 m ago

@WBLIBAdmin did you hear back from Comcast in a PM? Did adding DKIM not resolve the delivery issues for you? The Comcast rep said they don't require it and they found some other issue with emails from my domain getting flagged as spam and that they resolved it. If that's true then I guess the fact I added DKIM at the same time was just coincidental that it started working right afterwards. I haven't had any delivery issues since then. I'd still love to know exactly what happened, why emails from my domain were getting dropped even though they had perfect spam scores. I have a feeling I'm going to run into this issue with clients in the future and it would be nice to know what to tell Comcast next time 😕

New to the Community?

Start Here