richmz's profile
richmz
Expressive Exchange
Conversation Starter
1st Kudo

Contributor

 • 

21 Messages

Mon, Dec 14, 2020 7:00 AM

Email - Suspicious... email links now redirect to url.emailprotection.link

As of this morning around 9AM, any link in a email I view using Comcast webmail or via my Android phone(direct to Comcast email server) now goes to url.emailprotection.link first.

 

This does NOT occur on my PC using my Thunderbird email client, which I've been using for many years.

 

How did this redirect occur using Webmail or Android and how do I stop it?

 

Has the Comcast Mail Sever been compromised? Or did Comcast deliberately do this redirect now with no prior warning?

 

Rich

 

THis is what comes up to the direct link.......    url.emailprotection.link    There is NO other information anywhere regarding this sites validity.

URL Protection Information

 

All pages on this domain are part of an email security service that protects users from
phishing threats and other malicious links sent within email messages.

All links protected by this service are checked prior to a user opening the target page.
If the page is deemed safe then the system will prompt the user and allow them access to the target page, or it may automatically redirect them depending on how the system has been configured.

This page is for information only, you may now close this window

 

 

 

Responses

richmz

Contributor

 • 

21 Messages

6 m ago

Thanks. I cleared history and cache in the browser and still persists.

It appears that the redirect occurs only when the link in the email points to.....
https://www.repairclinic.com/Shop-For-Parts?query=WH43X10034

It doesn't redirect if just....
repairclinic.com

Strange

Rich
richmz

Contributor

 • 

21 Messages

6 m ago

I now see what happened, but I don't know why.

 

In my email, that link previously posted is not a direct link to repairclinic.com. That link actually points to....

https://url.emailprotection.link/?b7kFY5A-iHHRgiD_-DUlbVRXj3FOx97mv9kcB8mfMh7Az-GwISwsWu6GO-b2WBrKn7pQOlH6jJ2_B-4eEmTPNzOGoCUOwKWzeCekEpDC4vxmRk0oSAYZVdjin94hgBdKC

 

I created the link from the actual page on repairclinic.com(just a copy/paste like I always do) a few days ago and sent myself a email as a reminder. Mysteriously, the direct link was somehow replaced with the above redirect.

 

I have no idea how it happened, unless that site was corrupted somehow when I copied the link.

 

Rich

 

 

 

 

 

Latoque

Expert

 • 

28.8K Messages

6 m ago


@richmz wrote:

I now see what happened, but I don't know why.

 

In my email, that link previously posted is not a direct link to repairclinic.com. That link actually points to....

https://url.emailprotection.link/?b7kFY5A-iHHRgiD_-DUlbVRXj3FOx97mv9kcB8mfMh7Az-GwISwsWu6GO-b2WBrKn7pQOlH6jJ2_B-4eEmTPNzOGoCUOwKWzeCekEpDC4vxmRk0oSAYZVdjin94hgBdKC

 

I created the link from the actual page on repairclinic.com(just a copy/paste like I always do) a few days ago and sent myself a email as a reminder. Mysteriously, the direct link was somehow replaced with the above redirect.

 

I have no idea how it happened, unless that site was corrupted somehow when I copied the link.

 

Rich

 

 

 

 

 


I clicked on the link and got straight to the website.  I got no re-direct.  I sent it to my Comcast email address from my Gmail account and again got no re-direct when I clicked on it in the email.  I'm on a Mac, but I don't think that would make any difference with webmail.

 

I dunno------------🤔

 

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick
richmz

Contributor

 • 

21 Messages

6 m ago

Hi,  Sorry, I may have confused you in my previous post....

 

Yes you got directly to the link that I included in the post as it was a valid link, but in my email, the link: https://www.repairclinic.com/Shop-For-Parts?query=WH43X10034  

was redirected only in my email. When I place my cursor over the link in my Thunderbird email, it shows the redirect as shown in my previous post.

 

But as I'm writing this I just realized how this happened. I thought it was me, but it was them. The email that had the redirected link was actually FROM repairclinic.com Customer Service, when they replied to my email inquiry and Quoted my email with the correct un-redirected link that I sent to them. When they replied to me, that direct link I had in my email was now showing it redirected in their response.

 

I don't know if they did that intentionally. Maybe they use that software for any emails they send out. However, they have no information in the footers of their emails stating that. I may send them a inquiry  asking them about it.

 

Regardless, mystery solved and what I thought was some form of malware, etc in my email system turned out to be incorrect.

 

Thanks for your interest, feedback and help with this.

 

Regards,

Rich

 

 

 

   

 

 

New to the Community?

Start Here