johnk860's profile

Frequent Visitor

 • 

18 Messages

Fri, Nov 18, 2022 8:54 PM

Cannot connect with smtp outbound server

Receiving msg "Sending of the message failed.  An error occurred while sending mail. The mail server responded: Please ensure your email address and authenticating user match when sending messages. Please verify that your email address is correct in your account settings and try again."

This started yesterday.  I have not changed settings or passwords.  Up until a few moments ago, both my xfinity email addresses were affected.  Now my primary can send but my secondary address still can't.

Accepted Solution

johnk860

Frequent Visitor

 • 

18 Messages

5 days ago

I found my own answer, which may be one already posted that I'm reading wrong (regrets).  My item was to:

1.  Click on the account name (i.e. [Edited: "Personal Information"])

2. at the "outgoing server"line, click on "edit SMTP server"

3. enter any description (I use "comcast", just because)
4. Enter the server name, smtp.comcast.net,
5. ensure port (465). Security (ssl/tls), authentication (normal password) are all correct
6. Set user name to be the account name (e.g. [Edited: "Personal Information"])
7. Click OK
Repeat that for your second mail address ( [Edited: "Personal Information"]) using the same server name
Repeat for each of your other mail addresses

(edited)

Official Employee

 • 

442 Messages

12 days ago

@johnk860 Hello and thank you for reaching out over our Xfinity Community Forums. I am so sorry to hear about these email issues you are experiencing, that would definitely be really frustrating. You have reached the right place, and I would be more than happy to help in any way I can in getting to the root cause of the issue, and in getting you back on track again. To get started, could you please send our team a direct message with your full name and full address? Our team can most definitely take a further look at this issue.
To send a "Peer to peer" ("Private") message:
Click "Sign In" if necessary
• Click the "Peer to peer chat" icon
• Click the "New message" (pencil and paper) icon
• Type "Xfinity Support" in the "To:" line and select "Xfinity Support" from the drop-down list which appears. The "Xfinity Support" graphic replaces the "To:" line
• Type your message in the text area near the bottom of the window
• Press Enter to send it

Visitor

 • 

3 Messages

11 days ago

I have the same problem. I've used Thunderbird comfortably for years with Xfinity, & yesterday (Nov. 18) I got the error message described above by Johnk860. However, I have a clumsy workaround (in Thunderbird only!) that allowed me to send the messages that were bouncing off the Xfinity SMTP server: I went into Thunderbird via >Tools>Account Settings pulldowns. At the bottom of the resulting subwindow is an "Outgoing Server (SMTP)" line. At its end is an "Edit SMTP Server..." button, which I pressed to get an even smaller subwindow. At the very bottom of that subwindow is a "User Name" line.

The problem for me is that Thunderbird won't let me change this line for each of the 4 email accounts I have with Xfinity - it only allows ONE User Name, which I had set to the the one associated with the default account, for all 4 accounts. To send messages from the other 3 accounts, I have to temporarily change the User Name to match the account I want to send from.

It's clear that, at a minimum, the Xfinity SMTP server expects the "User Name" to be unique for each account, which isn't possible with Thunderbird as it currently stands. This appears to be a recent change at Xfinity, since Thunderbird has previously worked well for years with a single User Name for multiple accounts in the past.

I'm running Thunderbird 102.5.0 (64-bit) on Windows 10 (Version 10.0.19044 Build 19044).

(edited)

Official Employee

 • 

743 Messages

Hi there, @user_9ce0c9, thank you for taking the time to reach out on our Xfinity Forums and share you experience with us. Are you only receiving the issue when trying to send through Thunderbird? Have you attempted and are you able to send emails through our Xfinity Connect page?

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick
johnk860

Frequent Visitor

 • 

18 Messages

@user_9ce0c9​ Right click on the account name (the email address in the "Folders" menu) name and select "settings".  At the very bottom right is "Manage Identities".  Click on that.  The following screen shows the identity attached to that account.  If the identity is not what the folders menu says, edit it so that it reflects the email address of the folder, not your primary account.

Each mail address you use must have an equivalent identity that is the same as the email address.  Do this for each of your addressed any your problem will evaporate.  Probs? let me know an address and I'll send screen shots (peer to peer msg only.  Don't post your address in the forum)

Visitor

 • 

3 Messages

Thx, but my problem was related to the fact that I had all 4 of my accounts using the default SMTP server when edited as you describe above. In our case, I had used the default SMTP server for all of our accounts. (Hey, it worked for many years!) user_660f63 (see below) gave me the solution - I had failed to notice the "Outgoing Server (SMTP)" setting in the "Account Settings", so I came to the conclusion there was no way to set different identities on a single SMTP server ID. His workaround is entirely successful.

Official Employee

 • 

608 Messages

Thank you for the update and letting me know that everything is working again. Please remember that our Digital Care Team is available at any time, day or night, to answer any questions or concerns regarding your account. I hope you have a wonderful day, and please stay safe and healthy!

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

1 Message

11 days ago

I have the same problem with my Thunderbird POP accounts, but NOT with my IMAP accounts. Can anyone account for the difference?

Visitor

 • 

2 Messages

11 days ago

@user_9ce0c9 is on the right track! Up to now, I've used one SMTP profile for all of my many accounts. Neither Comcast nor Thunderbird never cared before.

When I go to account settings (in Thunderbird) and scroll way way down below all of my mailbox accounts, I see the "Outgoing Server (SMTP)" setting. Clicking there shows me a box. To the right of the box (maybe off screen for small screens) is a magic button labeled "Add..."

I think I'll add each of my Comcast email addresses and credentials. It'll be a pain, but I need to do it only once.

Have fun everybody!

Visitor

 • 

2 Messages

Success...

Added notes:

In each Thunderbird account, I needed to scroll to the bottom of its settings to choose my new SMTP profile to use it. Comcast does not support encrypted passwords. The first message sent will prompt for the account password, so you had better know it before you click send!

However, you can check the box to remember the password, so once you get it to work once, you can fuggeddaboudit.

Long story short: This is solvable with some power-user level Thunderbird-fu.

(edited)

Visitor

 • 

3 Messages

@user_660f53​, many thanks! I had failed to notice the "Outgoing Server (SMTP)" setting in the "Account Settings", so I came to the conclusion there was no way to set different identities on a single SMTP server ID (in this case, "smtp.comcast.net"). BTW, since my default account already had the User ID associated with the SMTP server, I didn't have to change it - now it's the only account using the default SMTP server setting.

Your fix is entirely successful. I just hope Xfinity notices it & adds it to the Thunderbird setup instructions.

(edited)

New Poster

 • 

4 Messages

@user_660f53​ I too had the same problem, all comcast emails using the same default outgoing server and no emails going out on accounts other than the default. For each of the email accounts (right-click on the email account folder, and select "Settings". The trick in Thunderbird is to go all the way to the bottom of the "Account Settings" tab's left side navigation panel, and select "Outgoing Server (SMTP)".  It is here where the Thunderbird user can "add" the outgoing server. Then, still in the "Account Settings" tab, select the email account and click on the "Outgoing Server (SMTP)" drop-down list, and select the SMTP server just added that matches the email address.

(edited)

Visitor

 • 

2 Messages

@quercus7​ Thank you all for your very helpful advice about this problem, which I started having at the same time as everyone else. I use Mac OS Mail, and following your advice, I was able to solve the problem for that application. Here are step-by-step instructions for anyone else using that application:

Mail > Preferences > Accounts

For each of your email accounts at a time, choose "Server Settings." In the drop-down menu under "Outgoing Mail Server (SMTP)," choose "Edit SMTP Server List."

This will give you a list of your servers and the email address that is using each one. Click on the server that a given account is using and make sure that the name in the "User Name" field matches the name in the "In Use By Account" column in the list. Fill in the password field if needed. Click "OK" after editing each account; you will need to choose the drop-down menu again to edit the next server.

If you find that you have two accounts using the same server, you will likely have another server that no account is using. In the Accounts screen, select one of those accounts and go to the drop-down menu and choose "Edit SMTP Server List." Then select the empty server (filling in password if needed) and hit "Save."

This worked for me, and I hope it works for you.

(edited)

XfinityAlex

Official Employee

 • 

541 Messages

5 days ago

Hey folks,

Let me know if you're still having troubles.  Yes, the policy is changing, though we're trying to allow folks to "grandfather" in and continue doing what they've been doing as long as they do so consistently.  I'm happy to inspect this for anyone who believes they're meeting the "grandfather" clause, and give exemptions where necessary.  We apologize for any inconvenience this may cause.   Also keep in mind that the webmail at https://connect.xfinity.com/ should work as well.

BruceW

Gold Problem Solver

 • 

24.2K Messages

4 days ago

@XfinityAlex wrote: "... Yes, the policy is changing ..."

What "policy" are you referring to, and what is changing exactly?

Please be aware that there are 2 kinds of responses in this Forum: Replies and Comments. When you Comment on a post by scrolling down to "Comment on this post here...", I am notified of your response. But if you select Reply, I am NOT notified and may not be aware of your response.
XfinityAlex

Official Employee

 • 

541 Messages

@BruceW​ Working to create a pinned post so it's not attached to this thread.

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick
forum icon

New to the Community?

Start Here