U

Visitor

 • 

2 Messages

Tue, Oct 26, 2021 12:18 PM

Closed

Can't seem to get Xfinity to ship my modem

I have ordered the XB 6 modem at least 7 times in the last month on priority shipment, and every time I am assured that I will receive it within 24-48 hours. Every single time I contact xfinity after a few days, I get the same response that it didn't ship due to technical difficulties and they reorder it. I've gone through this same cycle for almost a month now. I was told yesterday to go to the local store and that they checked and assured me that the modem was in stock - when I go there I was told they have been out of stock and weren't sure why I was sent in. Any tips on how to actually get a modem to achieve the speeds I am paying for?

EG

Expert

 • 

95.8K Messages

1 y ago

Concern moved here to the Customer Service help section for greater exposure to actual Comcast employees for assistance.

XfinityDevin

Official Employee

 • 

731 Messages

1 y ago

@EG Thank you for moving this over, EG! 

@user_2ba3b2

Good morning! Thank you for reaching out so we can help make sure you get the right equipment to enjoy the speeds you have. It sounds like you have had to wait quite a while and longer than we ever want you to. We can help make sure you get this modem so that you wont have to continue to wait. You are in good hands here online. We are able to help set up the order but also follow up and continue to support you from start to finish so we can ensure this is resolved.

Here's the detailed steps to Direct Message us:
• Click "Sign In" if necessary
• Click the "Direct Message" icon (upper right corner of this page)
• Click the "New message" (pencil and paper) icon
• Type "Xfinity Support" in the to line and select "Xfinity Support" from the drop-down list
• Type your message in the text area near the bottom of the window
• Press Enter to send your message

 

Would you send me a direct message with your first and last name and your complete address to get started, please?

Visitor

 • 

2 Messages

@XfinityDevinC Hello - I followed all of your steps and sent a direct message to XFINITY SUPPORT with the details needed.

forum icon

New to the Community?

Start Here