nothere's profile
nothere
Rousing Reactor
Expressive Exchange
Conversation Starter

Contributor

 • 

37 Messages

Sat, Jun 27, 2020 10:00 AM

Xfinity Internet with Flex - Not sure I'm getting Peacock Premium

I have a query into customer support, but maybe someone here can answer.

I just installed my Xfinity Flex and signed up for Peacock, and received verification that I successfully signed up for Peacock Premium which is free for Xfinity Internet customers with Flex.

But when I go into Peacock account info, it says my plan is Peacock Free (blue check), not Peacock Premium (which they say is $4.99).  It also says I am signed in as unauthenticated, even though it accepted my email and password. Customer support had be recycle Flex, but that didn't change anything.

 

Is this related to this being the "free trial" period, and maybe this will change on 7/15?

 

Responses

Frequent Visitor

 • 

9 Messages

1 y ago

I don't think I am getting Premium either.  Peacock wants a login/password everytime it is launched. Setup on Flex was just as it was outlined, including the launch of Peacock and sign-in.

I went into my account on Peacock and down to the  bottom where it has a LINK for Xfinity customers to link their account.  After I link it pops up a message that states "Sorry your Xfinity service doesn't include Peacock Premium".    So a fine mess, without resolution.  

 

Attempted to contact Tech Support at Xfinity yesterday but they make it extremely difficult to get directly to a live person who is technically qualified.

 

 

nothere

Contributor

 • 

37 Messages

1 y ago

After working with them via email and chat for 5 days, I finally got everything resolved and now have Peacock Premium.  It had to be escalated to the IT department.  Somehow my ID wasn't being authenticated on the backend, even though I registered successfully and logged in successfully. On the account screen it said "signed in as unauthenticated", and Peacock Premium was not checked (said I only had "free Peacock").  Then after 4 days of working the problem, it said "Signed In".  Then finally in the 5th day, it said "Signed in as ..... (my ID)"  and Peacock Premium was checked.  So it had to be a backend issue.

Frequent Visitor

 • 

8 Messages

1 y ago

How do you contact them via email?  I have the same problem, but can't find a way to contact Xfinity directly.

Frequent Visitor

 • 

8 Messages

1 y ago

Thank you!

nothere

Contributor

 • 

37 Messages

1 y ago

support@help.peacocktv.com

 

or

 

https://www.peacocktv.com/help/

 

(chat online in the lower right)

tsakmok

Frequent Visitor

 • 

15 Messages

1 y ago

I have same problem on Flex device I just got
It is a nice little streamer but this authentication issue is a problem COMCAST NEEDS TO FIX ASAP.
I emailed support@help.peacocktv.com as there is no number to call and chat is horrible. I waited 20 minutes after the chat person said hello and I described the issue. The only reply I got was a boiler plate applogy for taking so long but no details as to what was happening. Were they consulting an expert, was there a fire drill, what?
I dropped out at 21 minutes when they simply went silent.

nothere

Contributor

 • 

37 Messages

1 y ago

Like I said, it took me several days for Peacock/Xfinity to resolve the issue. They responded promptly to emails, but it would have been much more efficient if I could just call someone.  Then I tried Chat which was a little better.  Eventually tech support emailed me and asked for some info.   I took pics of a couple of screens for account/version as well as the bottom of the Flex box (for the MAC address) and sent it to them, and it was reolved a couple days later.

Frequent Visitor

 • 

9 Messages

1 y ago

My account was working today after I logged in on Peacock web site and clicked on Xfinity link. Flex also worked, right into Peacock and showed as Premium. I guess they fixed the authentication issue. 

New Poster

 • 

3 Messages

1 y ago

I am having the same issue.  I got my flex box before the launch and everyting was working great until July 13th.  I am guessing they did a update because the box restarted in the middle of a show and when it came back up it had me enter my email and password to create a peacock account.  After doing this, I had to enter the password, EVERYTIME, which I didn't before.  I too, noticed that I was only getting peacock free, not the premuim and when I go to the website to link the account, I get a message my service doesn't include it.  Mine too, says signed in as unauthenticated.  

I was on the phone with comcast for 3 hours, 7 agents and 2 dropped calls or hang ups with no resolution.  They said it was esculated to a higher tech team, but I haven't heard anything yet.  I have also contacted peacock tv chat and they could not help either.  

Really frustrating, but not surprised.  

 

New Poster

 • 

2 Messages

1 y ago

Same problem but I have the XG1V4 box, I spoke to both Comcast and Peacock with no solution other than it would be escalated and someone would contact me.

New Poster

 • 

3 Messages

1 y ago

Really sad.  I have been working with Peacock and now I am waiting on someone to call me.  As far as Comcast they were reaching out to their higher tech team.  I have heard nothing.  That was 4 days ago.  

New Poster

 • 

2 Messages

1 y ago

I have been waiting 3 days..

New to the Community?

Start Here