dennette24's profile

New Poster

 • 

2 Messages

Tue, May 5, 2020 11:00 AM

pixelization on some channels

I have pixelization on some channels and technicians have been here 5 times in the last 10 months. When they fix it the problem comes back in about 2 days.  Comcast told me to have an electrician change my cable lines so I had one come out and he said if he re-wired my cables it very likely would not fix the cable tv pixelling problem.  When Comcast techs come out they change fittings and boxes and again the problem returns soon after they've left.  Last time they replaced things in the ground in the box at the sidewalk but again the problem returned in 2 days.  When I stream on Netflix and such it doesn't happen - it only happens on some of the cable channels.  The pixeling is so bad you can't see a picture and even the audio is inaudible so it's not possible to watch the news on Channel 703 KCRA Please help!

Responses

Visitor

 • 

2 Messages

2 m ago

all channels or just some? have issue with ID and discovery network….maybe that is how they will get people to join their network, pay infinity for this now through a package.  can’t tell if that’s the issue it’s just those two though?  just was hoping for an explanation xfinity said it’s not the signal etc ?

Official Employee

 • 

142 Messages

Thank you for taking the time to use our community for support, we want to ensure this is addressed. However, considering this thread is over a year old, it will no longer be monitored. We ask that you please make your own public post if you need further assistance with your signal issue.

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

1 Message

2 m ago

If by pixelization, you mean that the channels are scrambled, we are experiencing the same problem. We have 2 TV's and it's only happening on one of them, which leads me to believe there is a problem with our box. I tried a reset and it did not solve the issue. Some channels are clear and some of the higher up, like channel 202 (Marquee, for us) are scrambled, with no clear picture or audio. I wish I could send Xfinity a video of the issue. I'm not sure where the problem lies. Can anyone help?

New to the Community?

Start Here