johnnycu2xx's profile

New Poster

 • 

1 Message

Sun, Sep 20, 2020 10:00 AM

it is a year later and you still havent fixed NFL games in Spanish?

I was looking for some answers and didnt really find any. My 88 year old mother is trying to figure out why she has to watch the Bears game inj Spanish. You people are less than compentent!

JordanM

New Poster

 • 

5 Messages

1 y ago

Okay after digging through the forums for like 30 minutes, I think I found the fix. I did it and haven't had any Spanish broadcast for the NFL game for like 10 mins after I did the switch.  You have to turn off "video description" in your settings.  If you have an X1 remote, hit the "B" button (above the number pad) and that should bring up your settings screen.  Scroll down to "video description" and make sure it's turned to "off".  That seemed to help me at least.  Good luck!

Visitor

 • 

2 Messages

@JordanM

Thank you!  That worked for me…really frustrating problem

Visitor

 • 

2 Messages

@JordanM 

thank you! That worked for me, really frustrating problem.

JordanM

New Poster

 • 

5 Messages

1 y ago

I came here to post a similar question.  For me, only NFL games on Fox broadcast in Spanish even though much like you, I verified that SAP feature is off and I have reset my cable box.  No other channels come in Spanish, and "regular" non-sports shows on Fox come in English...just when NFL is on.  Seems like a common problem they aren't addressing or trying to fix based on seeing other posts on this forum.  Sorry don't have an answer for you, but just letting you know you're not alone.

New Poster

 • 

2 Messages

1 y ago

Hi there.  I lookes at other forum answers, and this helped me.  My daughter's boyfriend just joined the Bears and I was dying for ENglish commentary.

 

While checking your SAP setting is a first good step, it may not be the fix.  It wasn't for me either...and only NFL games were coming in for Spanish for me as well (even though SAP was turned to "off").  After digging through the forums for like 30 minutes, I think I found the fix. I did it and haven't had any Spanish broadcast for the NFL game for like 10 mins after I did the switch.  You have to turn off "video description" in your settings.  If you have an X1 remote, hit the "B" button (above the number pad) and that should bring up your settings screen.  Scroll down to "video description" and make sure it's turned to "off".  That seemed to help me at least.  Good luck!

 

New Poster

 • 

4 Messages

10 m ago

Yay!!!!!  Thiis worked: on X1 remote, press B button, scroll settings to Video Description, turn it off. 

I'm glad you found and shared it.

You'd think Comcast would post this solution prominently rather than leave it to customers to dig through and figure out.  

Visitor

 • 

1 Message

1 m ago

I don't have the X1 remote or box but the small free box and the remote is very basic.  Any suggestions?

Official Employee

 • 

355 Messages

@user_031312 Can you please confirm the box model? It should be listed on a sticker on the back of the cable box. 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

1 Message

This is what worked for me: Pressed the down arrow under OK button on remote. Uncheck the SAP icon that comes up at the bottom of TV screen. 

New to the Community?

Start Here