Community Forum

Xfinity keeps asking me to activate my modem, wifi signal keeps dropping, can't reach agent

Highlighted
New Poster

Xfinity keeps asking me to activate my modem, wifi signal keeps dropping, can't reach agent

Please help, I've had my wifi and modem for almost 2 years now, but these past 3 days the signal has been dropping randomly, sometimes when loading website pages xfinity pops up asking me to activate my modem.

 

The signal keeps dropping and I have to keep switching between the main and secondary wifi networks, sometimes certain websites don't load and then after an hour or two it works. Or, for some sites I can't load them at all, but if I switch to the "xfinity" free hotspot wifi it will load.

 

We've already replaced the wifi cable, i'm not sure what to do. I've been on the phone waiting for an agent for hours this past week and no one will take our call. Other times, they won't even pass me onto an agent. Xfinity chat also won't pass me onto an agent.

 

Sometimes when they restart the modem through the automated hotline replies it will work again so they don't pass me onto an agent, but in an hour or two the signal will just die again.

 

Please please help, this has been very frustrating to work at home with.

Highlighted
New Poster

Re: Xfinity keeps asking me to activate my modem, wifi signal keeps dropping, can't reach agent

I've been having issues with connectivity as well.  At this point I am using my work cell hot spot to get on ZOOM meetings and work email, which is ridiculous.  My kids are constantly complaining about the wifi and every day they are restarting the gateway.  This has been going on for months.  I've tried speaking to an agent and it's impossible since the aotomated voice just wants to restart the gateway every time and then I never get a call back.  I am livid at this point! I know this isn't an answer to your post but I needed to vent.

Highlighted
New Poster

Re: Xfinity keeps asking me to activate my modem, wifi signal keeps dropping, can't reach agent

I'm having the exact same problem and it's driving me up the wall. I'm supposed to be in a training class right now for work but I'm missing it because Xfinity is demanding I activate my modem again and again and again.

Highlighted
New Poster

Re: Xfinity keeps asking me to activate my modem, wifi signal keeps dropping, can't reach agent

Has anybody had a resolution to this problem??
Highlighted
New Poster

Re: Xfinity keeps asking me to activate my modem, wifi signal keeps dropping, can't reach agent

I am having the same issue! This is happening for all of our phones connected to the xb7 gateway router/modem.