Community Forum

Xfinity Blocking Website

Highlighted
New Poster

Xfinity Blocking Website

Out of nowhere, I can no longer access vistaprint.com from my Xfinity internet.  One day I was working on the site, the next day this message (where the ref # changes every time i retry)

Access Denied

You don't have permission to access "http://www.vistaprint.com/" on this server.

Reference #18.4f7f1cb8.1581171494.99d82f4

 

I did a hard (using a pin) reset my router (correcting some IPv4 address issue), reset / removed all cookies, etc from my browser and have tried accessing the site via Chrome & Windows Edge - nothing works.   Vistaprint says it is not them and I can access the site using  AT&T's wireless service.  Any other ideas?  

Highlighted
Gold Problem Solver

Re: Xfinity Blocking Website

I can reach the site. "Access Denied / You don't have permission" messages are issued by the destination site, not by Comcast. It's likely the site is blocking your public Comcast IP. You can look up your IP at https://www.google.com/search?q=IP. You'll probably need to ask the site's admins for help with this.

What does a trace to www.vistaprint.com show? In Windows, open a Command Prompt window, enter

    tracert -4 www.vistaprint.com

and post the output. Mine looks like:

 

C>tracert -4 www.vistaprint.com

Tracing route to e14162.a.akamaiedge.net [104.102.197.34] over a maximum of 30 hops:

 1 24 ms 12 ms 10 ms  router1 [192.168.1.1]
 2 50 ms 17 ms 17 ms  96.120.9.181
 3 30 ms 19 ms 17 ms  te-0-6-0-0-sur02.york.pa.pitt.comcast.net [162.151.68.57]
 4 19 ms 18 ms 17 ms  96.110.24.214
 5 20 ms 20 ms 18 ms 96.110.25.65
 6 30 ms 38 ms 27 ms be-34-ar01.mckeesport.pa.pitt.comcast.net [69.139.168.141]
 7 59 ms 46 ms 34 ms be-7016-cr02.ashburn.va.ibone.comcast.net [68.86.91.25]
 8 41 ms 33 ms 33 ms  be-10142-pe01.ashburn.va.ibone.comcast.net [68.86.86.34]
 9   *          *           *           Request timed out.
10 49 ms 40 ms 43 ms ae5.ctl-iad.netarch.akamai.com [23.203.152.150]
11 44 ms 33 ms 33 ms  a104-102-197-34.deploy.static.akamaitechnologies.com [104.102.197.34]

Trace complete.

 

Highlighted
New Poster

Re: Xfinity Blocking Website

I had the same issue which started on Friday 2/7/20. I tried everything and nothing worked. I finally called Xfinity and after putting me on hold for a while the rep came back and said that it was not their doing and that they had nothing to do with it. I am frustrated now. the only way I am able to log into my VistaPrint is by using my phone with the wifi turned off and just using my phone data. and that is how I was able to confirm that this has to do with Xfinity but they claimed that there was nothing that could be done on their side.


@M-POWER wrote:

Out of nowhere, I can no longer access vistaprint.com from my Xfinity internet.  One day I was working on the site, the next day this message (where the ref # changes every time i retry)

Access Denied

You don't have permission to access "http://www.vistaprint.com/" on this server.

Reference #18.4f7f1cb8.1581171494.99d82f4

 

I did a hard (using a pin) reset my router (correcting some IPv4 address issue), reset / removed all cookies, etc from my browser and have tried accessing the site via Chrome & Windows Edge - nothing works.   Vistaprint says it is not them and I can access the site using  AT&T's wireless service.  Any other ideas?  


 

Highlighted
New Poster

Re: Xfinity Blocking Website

it might be that the Content delivery service is blocking the ip addresss. you can check here: https://community.akamai.com/customers/s/article/Why-is-Akamai-blocking-me?language=en_US